Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been doing a lot of research with no reasonable solution. Please excuse the length of my post.

When I plug my Galaxy Tab 2 (7" / Wi-Fi only / Android ICS) into my Windows 7 64-bit machine, I (almost always) get this warning popup that "This device can perform faster."

And in fact, transfers onto the Tab in this mode are slow. The two times I've been able to get a high-speed connection, the transfer has occurred at the expected speed. I just don't know what to do to get that high-speed transfer. (The first time I did, it was the first time I connected the Tab; the second time I did, I was fiddling around and unplugging/plugging in again.)

That popup is telling me that the device is USB2, but that it thinks I've connected to a USB1 port. In fact, every USB port (there are ten) on this system is USB2. It's an ASUS M3A78-EMH mobo from late 2008. I'm not sure what the chipset is; the CPU is an AMD Athlon 4850e, but I've seen this message reported for non-AMD systems. (Every mobo reference I've seen in reports on this has been for Asus, but of course most reporters aren't reporting that info at all.) The Windows 7 installation is just a couple weeks old (I had a disk crash) but I saw the same warning on the WinXP/64 that was installed previously.

In Device Manager, there are two "Standard Enhanced PCI to USB Host Controller" nodes which are the actual high-speed controllers. There are also five "Standard OpenHCD USB Host Controller" nodes, which I have determined are virtual USB1 controllers embedded in the "Enhanced" controllers. (In Device Manager, I'm using View|Devices by Connection.) My high-speed thumb drives, external disks, and iPod all show up as subnodes of the "Enhanced" controllers; the keyboard, mouse, and USB speakers under the "OpenHCD" ones -- and this is true no matter which ports these devices are plugged into.

The Tab shows up under an OpenHCD node, unsurprisingly. It appears as a threesome: a top-level "Mobile USB Composite device" with two subs: "Galaxy Tab 2" and "Mobile USB Modem." (I have no idea what the modem device implies or how I might use it, but I don't care about it either: I just want the Tab to reliably connect at high speed.)

On the Tab, the USB support has a switch between PTP and MTP, the latter being the default, and the preferred mode for me (as I'm usually hooking it up for music synch). I have tried, however, connecting it as PTP, and it still connects as USB 1. (As PTP, only the "Galaxy Tab 2" device appears -- no Composite, no Modem.)

If it's plugged in as MTP and I change the setting to PTP, Windows unloads and reloads the device, and voila: The Tab appears under an "Enhanced" node, but eventually re-loads again to show a exclamation icon on the device; Properties then shows "This device cannot start." Same response if I plug it in as PTP and then change to MTP; in this case, only the Tab itself shows the exclamation, not the other two devices.

One thing I have not tried, and really would prefer to avoid, is installing the "beta" chipset driver available on the Asus website, which is dated 2009. Windows tells me it has the most up-to-date drivers for the Tab, and for the chipset, and I'm inclined to believe that.

I suspect the problem is with the Samsung drivers, or possibly the hardware. One suggestion I saw elsewhere which might, possibly, pertain is to ensure the USB cable is properly shielded; however, the Tab has one of those misbegotten 30-pin, not-quite-an-iPod connectors; I don't know if I could find a 3rd party one. It seems unlikely that this cable is improperly shielded, tho. (Is there a way to test that?)

So, my question is: does anyone know how to get this working as one might reasonably expect it to?

EDIT: Just to follow on, I wanted to mention that some other thumb drives -- in particular, a 2004-era Cruzer which has long been always-connected to the computer, with no problems at all -- have occasionally been putting up the "Can perform faster" message even when the Tab is not connected. Just this morning I woke the computer from Sleep, and the message popped up, even tho the Cruzer was the only drive connected and had been connected as USB-2 when the computer went to sleep. (And the Tab has not been connected to the computer since the last restart.) In the case of the Cruzer, a single eject + reconnect has (so far) always been sufficient to get it back to normal.

share|improve this question
1  
Post length is irrelevant, Its better when people take the time to write good quesions with what they tried and other information. –  Adam Jun 24 '12 at 1:09
    
well, this can be caused by loose ports(i face it every day!)..try using a different port and a different data cable.. reinstall samsung suite which will reinstall the drivers for your tab. –  tumchaaditya Jun 25 '12 at 6:38
    
@tumchaaditya: the problem occurs on three or four different ports. I did reinstall Keis (which sucks) while the Tab was plugged in, and after all the driver reinstalls, it did show up as USB2. And then I unplugged it, plugged it back in, and the same problem. –  Mike C Jun 28 '12 at 2:17

2 Answers 2

I also had a USB problem with the Kies PC drivers, but in my case for Galaxy S2.

I solved it by installing New PC Studio just for its drivers. This is older software than Kies, probably its predecessor. In my case I installed it after installing Kies and didn't reinstall Kies afterward. Although many updates of Kies have been done since with newer versions arriving regularly, the driver was never updated by them.

New PC Studio is now hard to find on the Samsung site but is easily found elsewhere, for example here.

This fixed the USB problem for my Galaxy S2, but might not apply to your Galaxy Tab.

share|improve this answer
    
I initially accepted this answer, but un-accepted because the solution did not stick. I thought at first that running NPS and making the connection, solved the problem, but it did not; subsequent connections, with or without NPS running, still connect as USB1. The driver version I see now (for all three USB nodes) is 2.9.317.215. I failed to note the version installed at the time I posted the question, but that number does not look familiar, so I think the driver has in fact changed due to the NSP install. –  Mike C Jul 4 '12 at 4:31
    
Just to remark that I have installed the latest Kies on a new computer and had no problem. I only needed to reboot, then plug-unplug the phone a couple of times for it to connect. –  harrymc Jul 8 '12 at 10:11

Check this out. Don't know if it works for you. But it is worth trying. Please let me know if it worked.. http://www.samsunggalaxysforum.com/kies-problems/kies-connection-problem-fixed/

share|improve this answer
    
Welcome to our forum. Just to remark that: (1) It is preferable to give some details when linking to a solution, (2) The solution here is same as my answer. –  harrymc Jul 2 '12 at 5:31
    
Thank you for pointing out. I will take care from my next answer onwards. –  gladiator2345 Jul 2 '12 at 10:10
    
No problem. Cheers. –  harrymc Jul 2 '12 at 10:15
    
Why not fix this answer? –  Al E. Jul 18 '12 at 13:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.