Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to recover files from a harddrive which is probably slightly damaged. It's a 3.5' SATA harddrive, connected via USB adapter to a macbook. When plugged in it shows up in the finder as usual. When I then start to copy files from the hd it works as expected. After some time (a little bit more than 3 GB) it suddenly stops and OSX complains that the hd had been removed. When I then disconnect the hd from the macbook and power and plug it in again, the hd shows up in the finder again and "works" for some time..

I also tried to make a raw copy of the disk using dd with a block size of 10m this completely failed, it started but then stopped with a "Device not configured" error and an empty output file.

I wonder if anybody had experienced similar problems and what might cause the hd to fail.

share|improve this question
    
Try a different USB adapter perhaps? And/Or perhaps, try it on a different computer? –  Ƭᴇcʜιᴇ007 Jun 24 '12 at 20:00

3 Answers 3

up vote 2 down vote accepted

Try using dd_rescue. It works essentially the same way that dd does but if it encounters bad sectors it will skip over them and continue the cloning process. Assuming there aren't many bad sectors you should be able to get the majority of your data off the drive.

As I'm sure you're aware, be careful when you use dd_rescue. It can destroy your data if used incorrectly.

It is also worth mentioning that USB is slow and unreliable compared to a directly connected hard drive, not sure if that is a possibility for you but just something else to think about.

share|improve this answer
    
Thank you! The first helpful answer. I was unaware of dd_rescue. –  Nils Jun 26 '12 at 7:29

I tried to recover data from my laptop which had fallen. Each time it went dead after half an hour and even made my computer almost crash.
The problem was some dead sectors which my computer (apparently) couldn't handle. I was able to recover all the data except for a few files which were corrupted.

So my question to you:
Are you trying to access a certain file every time the hard drive gets disconnected? If so, try to access other files instead and see if you can recognize a pattern in the crashes.

share|improve this answer
    
Not sure, but I don't think so. Remember that, because of this, I also tried a raw dump of the disk which failed. –  Nils Jun 24 '12 at 17:22

Does the external 3.5" (!!) drive have it's own power supply too, or is it supplied from the USB?

If it's powered from the USB, then it's likely that it's suffering from a form of brownout and dropping out. If it IS powered from the USB, I'd recommend using an external powered hub, as it'll be able to sustain more power over time than the computer's USB.

EDIT>>

Since it's not a power issue, it's likely a bad sector on the platters. If you're using linux, you could try this to make an image of the drive:

dd if=/dev/sdX of=hgimage.img bs=1024

Then when it dies (eventually), it'll display how many 'blocks' (of 1K in this case) were successfully read. Then you can do:

dd if=/dev/sdX of=/hdimage2.img bs=1024 skip=????

putting the number of read blocks +1 in the skip field. (Change the image name (of=) to keep all the parts to later reassemble)

Progressively repeating this can help recover much of the drive, you might also try ddrescue (or dd_rescue, there are two similar programs which do almost the same thing). These will recover from read errors and skip to the next block to continue... it'll take a while, but it'll make a decent image of the icky drive, although it'll have zeros where it couldn't read something. At least the structure would be intact.

ddrescue/dd_rescue also supports restarting a read, as it can be told to skip what it already has + some skip distance. Worth trying.

share|improve this answer
    
Well it's just a "normal" 3.5'' hard drive connected externally via USB. –  Nils Jun 24 '12 at 17:20
    
It is powered from an external source. –  Nils Jun 24 '12 at 17:21
    
I don't have a different adapter, but on a different computer it is the same problem. –  Nils Jun 25 '12 at 5:52
    
I'd imagine it's something like @mixxiphoid's answer... there may be a (really!) bad sector, which causes the drive's little brain to lock up. You might try narrowing down the copy operation to see if it's localized to a particular section. Best of luck. –  lornix Jun 25 '12 at 6:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.