Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Modem. When I do 192.168.1.1 on the browser, I get the following screen

enter image description here

I assume it also router. My reason for this assumption is it has options for IPv4 Routing as show in the below image

enter image description here

The option on pressing the configuration are

enter image description here

The page under ipv4 routing is

enter image description here

Also, I have a D-Link Wireless N 150 Access point and I have a dial-up connection from an ISP and I get a dynamic IP every time I connect to the internet.

This is how dail-up a connection

enter image description here

My Question

I wish to set-up a Wi-fi network in my home and wish to use this internet connection on my 2-Android phones, 2-Laptops and Ipad. Can I do with the hardware I have, if yes HOW?

What I tried

A. I connected Dlink AP with the BSNL Modem.

B. I disabled DHCP on Dlink AP as shown in the image below

enter image description here

C. Opened the Wi-fi switch of laptop. A Local Wireless network is shown in the Network and Sharing center.

But I was unable to connect to the internet. I have one doubt, this connection in dail-up and I have to enter a name and password(stored) everytime I connect, so in this case, how will dail-up happen.

share|improve this question
    
Has your ISP assigned you a static IP address? –  ChrisF Jun 24 '12 at 12:48
    
No. My ISP don't provide a static IP. –  Gaurav Agarwal Jun 24 '12 at 12:52
    
In that case at the very least you'll need to change that option. –  ChrisF Jun 24 '12 at 12:53
    
Can you help me with this question? –  Gaurav Agarwal Jun 24 '12 at 12:55
    
@darkcrow Can you provide the results of an ipconfig /all in the question, once you connect to the AP? –  Paul Jun 24 '12 at 12:58

4 Answers 4

up vote 1 down vote accepted
+50

The problem is that the DSL modem is configured as a bridge, not a router. In this mode, the DSL modem has no IP-layer connection to the ISP. The Windows box is running a PPPoE client (which acts like a dialup but runs over an Ethernet network), so it has the IP-layer connection to the ISP, but it is not providing services (like DHCP and NAT) to the other network clients.

The solution is to get the PPPoE client running on the DSL modem, and enable its DHCP server and NAT if not already enabled. blasteralfred's answer contains a useful link to setup instructions for your modem (even though his version has wifi built in and yours doesn't). Specifically, Step 1 of those instructions has a link to http://www.corenetworkz.com/2010/06/configure-internet-connection-in-bsnl.html which is the PPPoE setup.

share|improve this answer
    
What more things you can imagine fixing? One of my Android phones in not not able to connect and another looses IP intermittently though my laptop and ipad are working like charm. –  Gaurav Agarwal Jul 29 '12 at 22:29

Yes, you have everything you need. Connect the wireless access point to the BSNL modem. Use a LAN port on the D-Link, and connect to the modem on the same port that you would a PC.

Then connect anything wired to the AP (or modem if it has additional LAN portS) and setup wireless on the AP. Disable DHCP on the AP.

Because you have connected these in a LAN configuration, they are on the same broadcast domain and so devices connected to the AP can use the DHCP server on the modem to get IP addresses and DNS settings.

This is all you need to do.

share|improve this answer
    
I could not connect to the internet, I have edited the question to describe the problem. –  Gaurav Agarwal Jun 24 '12 at 12:47
    
Try to ping 192.168.1.1, your modem –  Nam Phung Jun 24 '12 at 15:30
    
Thanks @NamPhung I could ping the modem and I am now connected to Internet but only on laptop, both Ipad and Android phone has Wi-fi ,but are unable to connect to internet. –  Gaurav Agarwal Jun 24 '12 at 16:09
    
Did you assign static IP to your computer. Try to access 192.168.1.1 by safari. If you can't then there is properly problem with the IP configuration. –  Nam Phung Jun 24 '12 at 16:16
    
@NamPhung I tried accessing 192.168.1.1 from Opera Mini in Android and it could not connect and I did not assign static IP to the computer. –  Gaurav Agarwal Jun 24 '12 at 16:22

I am using BSNL Modem and I have Wireless access to it. Here is the link, with images, to help you configure your modem. Always create a secure connection, with pass key, to prevent others from accessing your router.

http://www.corenetworkz.com/2010/06/setup-wireless-and-security-in-teracom.html

Hope this helps. :)

share|improve this answer
    
It don't have a teracom wireless router/modem. I am trying to connect a DLin k access point to the wired teracom router/modem. –  Gaurav Agarwal Jul 29 '12 at 16:11
    
do you have a blue+black teracom modem with an antenna at back? –  blasteralfred Ψ Jul 29 '12 at 16:14
    
No I have a while teracom modem and it does not have any antenna. The access point is Dlink it is black and has an antenna. –  Gaurav Agarwal Jul 29 '12 at 16:26
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Oliver Salzburg Jul 29 '12 at 17:16

When I run into problems it usually helps me to make a (paper) drawing of a network.

This is the one which I get if I put you information into one: Diagram showing the network as descriped by the OP

The internet connection arrives at the red line. It is only active after your 'dialled in'.

Since you almost certainly only get one IP from your provider it will be assigned to the modems external interface. This is the only place where you can directly communicate with the internet.

To allow internal devices onto the network your BSNL modem does a few things:

  1. It hands out non routeable IPs to devices on your internal (green) network via DHCP.
  2. It makes sure its own IP is in the same range. (192.168.1.x).
  3. If an internal IP wants to access something on the internet it uses network address translation.

As far as I can tell this part works fine.


However the modem does not have wireless, so you added another device to the network. A Dlink AP.

You connected this AP to the DSNL modem and gave it an IP in a different range. (192.168.0.50). As a result it can not communicate with the 192.168.1.x network.


If all of this is correct, then you can gain access to the internet via wireless if you:

  1. Put the DLINK in the same network range as the BSNL modem, either by

    • setting the DLINK to DHCP so it gains a 192.168.1.x address, or
    • manually set the DLINK to an unused 192.168.1.x address.
      (preferably one outside the DHCP range from the BSNL modem.)
  2. If the DLINK has a DHCP server then disable it.

Now the DLINK should be able to communicate with the internet. Only one step remains: making sure that wireless devices which connect to the Dlink can also reach it. To do this the Dlink will have to forward these connections without using additional masqerading or address translations.

According the the link to provided for the Dlink it supports 'bridge mode'. Enable this.

If all is as a I drew it in the schematic, then it should work.

However the dial up connection part really surprised and confused me. If this is just something which gets sent to the modem and which forwards it then things still should be correct. If it is indeed more of a 'real' modem rather than a regular broadband modem then my explanation will need to be changed.

Edit: The more I think about it and the more the previous answer feels wrong. I am sure it is correct for the normal 'broadband modem-router-firewall' which seems to be the only model I ever see around here. But I found some manuals on the internet which make two other solutions more likely.

The first is the easy way with an always on server. That would yield this configuration: Network schematic with modem connected as an old fashioned dial in modem

This would require you to 'dial in' from the server/laptop. Connected via the normal cable.

Once that is done you can share the internet access with the rest of your home network.

If you have two network cards in your server/laptop:
Enable internet sharing. Done.

If you only have a single network card in your server/laptop:
Add a second IP to the network card, then enable internet sharing.
(Note: I wonder if windows allows DHCP and an extra IP via the GUI. This might require some scripting)

If you do not run windows on this machine (e.g. because you want to use your regular laptop and scavenged an old PC with GNU/Linux)

  • Set up the dial in connection
  • Assign the second IP address (same as in windows with 1 or 2 NICs)
  • Add routing table entries.
  • Enable forwarding. ( sysctl -w net.ipv4.ip_forward=1 )
  • Enable IP Masquerading.


Wow, this is really getting a long post. However I still have more more schematic.

The Dlink AP has two wired ports.

That means that something like this is also possible:

enter image description here

Basically you would 'dial-in' from the laptop at the bottom of the picture, using the Dlink as a bridge. I am not clear what the result after that is. You would have a working connection from the laptop, but I could not find precisely how the laptop gets configured. As a result it is likely that you will need manually set DNS on the Dlink. If the Teracom modem acts as DHCP server then you will need to disable this on the Dlink. If it does not you will need to have it enabled.

This post is getting dratfully long. Please, read it, comment on which of the two is wrong (think of it as options 1 and 2a, 2b) and I will expand the correct part.

share|improve this answer
    
Hi, there is another possibility. Have a look at @Alan Curry answer and it worked like a charm. –  Gaurav Agarwal Jul 29 '12 at 22:27
    
Aha. I figured the screenshots did not show IP or routing because you where not not dialed in when the screenshots where taken . Now that I know this is because you can enable or disable that functionality things suddenly make much more sense. –  Hennes Jul 29 '12 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.