Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just got a new imac 27" and it has been turning the sound on and off byitself like someone was hitting the mute Key on the keyboard over and over. It will work fine for a while and then it will just start flashing off and on over and over. I tried restarting, looking in the sound menu, etc but couldn't find anything. The speakers work fine and the noise is good when it is working but the constant on and off is an issue. Hoping a simple fix rather than return.

share|improve this question
    
Is or was there anything plugged into the headphone jack? If it's new, just return it for another model. –  slhck Jun 24 '12 at 12:56
    
No nothing was plugged in to it ever. Ugh thats annoying. Guess i will call best buy and hopefully they can bring an exchange out. I dont want to have to take it somewhere. –  Matt Jun 24 '12 at 13:00
    
I can't think of anything else. If the sound is off, try grabbing a screenshot from System Preferences » Sound and see if there's any input device missing. It could be due a broken latch in the headphone port signaling an optical cable plugged in. I've seen that happen, however that was because of people abusing the jack, tearing out cables and such. –  slhck Jun 24 '12 at 13:06
    
Thanks for the insight. I tried plugging headphones in and the same thing happens. The mute/not mute just flashes back and forth frequently. Hopefully they can make a quick fix/switch. Wish I hadn't taken the time to move everything over already though! –  Matt Jun 24 '12 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.