Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Logitech MX Revolution wireless mouse that I am trying to use with OS X Lion. Everything is working except for one problem... there is a small, but quite noticeable, jump when the mouse cursor is moved. The problem is mostly prevalent when dragging and dropping files or trying to highlight items. It makes performing any task with the mouse accurately next to impossible. I did quite a bit of looking and found that all kinds of people have had mouse issues with OS X. I've tried all of the following with absolutely no success:

  1. Using the official drivers from Logitech (these performed worse than the default mouse drivers in OS X)
  2. Using SteerMouse as a third party mouse driver. This worked ever so slightly better than the default driver, but still suffered quite frequently from the skipping problem
  3. Cleaning the sensor on the mouse and ensuring it's not the result of the surface that it's being used on.
  4. Tested the mouse on a Windows machine. The mouse worked absolutely flawlessly on the other machine.

  5. Changed the channel that my wireless router operates on by the off chance my problems were the result of interference. This also had no effect. I can't think of anything else that could possibly interfere with the mouse.

I'm am out of ideas on what to try, so I would really appreciate if anyone has any suggestions. I should also mention that an old wired mouse I had laying around worked just fine when I plugged it in. This really isn't the best solution, however, as I really prefer the MX Revolution.

share|improve this question

2 Answers 2

I finally managed to get it working. I tried a whole myriad of things, but what finally worked is installing the Logitech drivers. Once installed go to Applications->Utilities->Logitech Unifying Software. From there click on the button that says Advanced. On the left you should see a list of the Logitech wireless devices currently paired to your computer. All I did was select the mouse and select the option to un-pair the device. I then re-paired the device with the computer. Everything seems to be working perfectly now!

share|improve this answer

TLDR: Try installing smoothmouse.com.

According to the smoothmouse forum:

Fact: the on-screen pointer lags behind the mouse (or trackpad) in OS X more than in other operating systems, such as Windows or Ubuntu Linux.

To sum up: The problem has been confirmed by an Apple engineer (thanks to him for that) in an email correspondence with me. He has also mentioned that they were working on a solution. The problem has existed at least since OS X 10.4 "Tiger". The current version of OS X (10.8 "Mountain Lion") still exhibits the problem. Many people confuse lag with acceleration, this is what my blog post was about.

Solutions:

  • SmoothMouse.
  • Running Mac as a Synergy client with a mouse connected to another computer running Synergy server.
  • Using Wacom tablet instead of a mouse.

Installing SmoothMouse probably best bet...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.