Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to create a dvd for an offline version of a site (for language learners) and would like it to autorun. However, it appears not to work on Windows 7. The autorun.inf file is only:

[autorun]
shellexecute=index.html

Can anyone tell me why this isn't working?

share|improve this question
    
Added autorun tag & put the code into a code block for clarity, please check that it is correct. –  Julian Knight Jun 25 '12 at 11:22
    
See this answer and use the autorun pro to fix it. –  avirk Jun 25 '12 at 12:03
add comment

1 Answer

This appears to be correct.

You could also use something like:

[autorun]
open=command /c start /max index.htm

You might want to try that just to see if it works.

However, I suspect the simplest answer would be that you have autoplay disabled - perhaps though some previous tweaking of Windows? Or via a Group Policy if it is a PC on a Windows Domain. If you insert a blank CD-R or DVD-R, do you get the pop-up dialog? If not, then autoplay is disabled. You need autoplay enabled in order to run autorun.inf

If autoply is disabled and if you are confident editing the registry and you are not on a PC belonging to your enterprise (unless you have authority), you could try editing the registry. I believe the correct entry is found at:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

There should be an entry called "AutoRun" and it should be set to 1 not 0.

To check the group policies, run gpedit.msc and go to the section "Windows Components \ AutoPlay Policies". The set "Turn off Autoplay" to disable.

Microsoft provide some pointers to autoplay security issues here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.