Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using CentOS 6.2 and I want to disable automount of pendrive.

what is the procedure?

which file should I edit?

share|improve this question

2 Answers 2

As root or sudo:

/etc/init.d/autofs stop

If you don't want it to come back after a reboot, do this as well:

chkconfig autofs off

Now you will have to mount your devices manually. Actually this isn't the case on my SL6.3 box, so I was wrong, I guess it has to do with udev.

And Finally here is the answer you probably want: http://www.tuxradar.com/answers/706

share|improve this answer

You need to go into the /etc/fstab file, and assign the no-auto flag to your drive. I don't know how to comment on your question (which I would do, since this is not a complete answer), but I'll post it here to help out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.