Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently, I tried to crosscompile Perl on my Ubuntu system but made a mistake. The finished binary was installed on my productive system besides the already present perl version. Ever since I get the following error when running a perl script:

/usr/bin/perl: symbol lookup error: /usr/bin/perl: undefined symbol: PL_perl_destruct_level

Of course I removed my version but the problem persists and the error event appears when I try to reinstall perl with apt-get install --reinstall perl.

Could anybody help me fixing this problem and save my Ubuntu from reinstallation?

Cheers, Anonymous Coward

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I've solved the problem by copying a perl-executable from an other installation and running

apt-get install --reinstall perl
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.