Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got rid of a rather annoying virus that spreads on removable disks. The problem is that I can no longer double click a removable drive, and it seems to be showing the folder icon rather than the removable disk icon. I have tried to change the "folder" and "drive" types both in Folder Options (although the edit button is greyed out for some reason), and in the registry, and neither seem to have much effect on the removable disk. Even when I add another option eg. "open2" to Folder that runs explorer.exe, it appears in the right click menu for the disk but I still get the same error message regardless of which option I click.

This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.

Indeed, there is no option for a "Removable disk" in folder options or the registry, and yet it seems to inherit options from Folder, even though they don't work.

When removing the virus, I cleared every registry entry that mentioned it. Could I have deleted the removable disk entry entirely? If so, how can I restore it?

Edit: Okay, this is weird. When I spam the f5 key, I can see it loading the CORRECT icon, then suddenly switching to the folder icon...

share|improve this question
up vote 1 down vote accepted

Check the tools at this reference.
Since you know the drive letter where it was mounted, you could use the RemoveDrive tool.

There was one case where the remove disk icon
(in the tasktray actually) also reappeared after using RemoveDrive.

share|improve this answer

Seems to be fixed after a reboot. As far as I can tell, it was still using the (deleted) autorun file from the virus...

Thanks to the above tools, autorun is now permanently disabled, so I shouldn't get the problem again. Thanks!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .