Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have perl 5.8.8 installed on a production linux system, and there are many, many packages installed. I am planning on installing perl 5.16 under a prefix (from source). Is there any way for me to tell cpan that I want to install into this new location the latest version of all packages that currently exist in the existing installation?

I can write a script to walk my current PERL5LIB to build a list of things to install, but I am hoping there is some way pre-built way to do this.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

It sounds like you are looking for the autobundle feature, which creates an installable 'Bundle' of all the Perl modules on your system.

I recommend against installing the newest versions of all the modules. Instead, I recommend installing the same versions. There are is no guarantee that the newer versions are compatible with your application. Unless you have a comprehensive test suite, you are increasing the risk of your upgrade by expanding the scope of work that needs to be tested.

I recently upgraded an app with more than 100,000 lines of code from 5.8 to 5.14, and it went surprisingly smoothly. We stuck with the same versions where we could and found there was high compatibility.

share|improve this answer
    
this appears to be what I was looking for, thanks. –  frankc Jun 25 '12 at 18:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.