Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After upgrading to OSX 10.7.4 I had to reinstall GNUPLOT which is always a hassle. I decided that I would try Homebrew instead of Fink or MacPorts.

Ofcourse, before installing Homebrew one needs the Xcode application and together with it the Xcode CLI kit (I first installed the latter one as it looked as if that would suffice, but the Homebrew doctor recommended installing the XCode app also...).

After some reading I got the impression that when installing GNU Octave (which I might also need later on), Homebrew would also install GNUPLOT. This did not happen and after an hour or so the Octave installation also failed. Then I decided I was not interested in Octave itself at the moment, but only in GNUPLOT and installed that by doing 'brew install gnuplot' which was rather quick as most of the dependencies were already there.

Anyway, when using GNUPLOT (with Apple's native X11) I can plot a few things, but when exiting or when replotting some data files I get the following error:

gnuplot> exit
gnuplot(406) malloc: *** error for object 0x6d72657420746573: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

I'm not sure how to debug this, tried reinstalling with brew (and also checked the deadlines installation), but without any result.

Any input on this? Cheers,

share|improve this question

1 Answer 1

Try switching the readline to the built-in readline: http://head-lights.blogspot.com/2013/09/gnuplot-mountain-lion-and-malloc-errors.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.