Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed the mcrypt library, but for some reason Apache disregards it. The files are in place, reinstalling invokes messages that newest version is already installed.

Any ideas?

share|improve this question
3  
Does it show up in phpinfo()? What kind of error do you get when you try to call an mcrypt function? –  AaronLS Sep 20 '09 at 14:46
    
It doesn't show up on phpinfo(). The only error message I can describe is the one I get from phpMyAdmin, that mcrypt it cannot load the mcrypt extension. –  Konzepz Sep 20 '09 at 14:56
add comment

2 Answers

Have you tried restarting apache after installing?

Edit: Yes, that's how I would restart it. Also FYI, after installing the mcrypt extension, you must then recompile php with the --with-mcrypt=/usr/local/bin/mcrypt option, except use the path to where the mcrypt extension is installed.

There are two individuals in the comments on this page who experienced the same error. Might try their suggestions: http://us3.php.net/manual/en/mcrypt.setup.php

Also, note the comment here regarding the same error: http://us3.php.net/manual/en/mcrypt.installation.php

share|improve this answer
    
I did, like so: "sudo apachectl restart". Any other way I should know about? –  Konzepz Sep 20 '09 at 14:55
    
Also used "sudo /usr/sbin/apachectl restart" –  Konzepz Sep 20 '09 at 15:00
add comment

Which platform do you use? Are you using a Mac? Installing an Apache module on a Mac can be a tricky process.

share|improve this answer
    
Also, "how did you install the module?" - i.e. using a pre-built package, or by compiling it yourself? –  Rob Oct 4 '09 at 18:46
    
Operating system also helps... –  Jakub Apr 29 '10 at 18:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.