Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've created an SVN repository and exposed it to the outside world using the WebDAV module in Apache (proxified through nginx), but I'm unsure how to make it read-only.

This is what my config currently looks like:

<VirtualHost *:300>
        <Location />
                DAV svn
                SVNPath /var/svn/repos/dayz

                AuthzSVNAccessFile /etc/apache2/svn.conf

                Satisfy any
                Require valid-user
        </Location>
</VirtualHost>

When I try to commit however, SVN shows this:

I'm expecting to see a "not allowed" message instead. How do I configure this properly?

The repository will only be edited from within the server itself, so essentially I want WebDAV to only allow for directory listing and GET requests. Is it possible to do this without settings an anonymous user?

share|improve this question
add comment

1 Answer

I solved it for now by blocking any requests besides GET, OPTIONS, PROPFIND and REPORT.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.