Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently begun getting the error "The remote computer requires Network Level Authentication, which your computer does not support." when trying to connect to a Windows 7 host that I recently made some changes to, including stopping/disabling many services and start-up applications whose purpose I do not know.

Two clients I have tried connecting with used to work connecting to this host, still work on Windows 2008 server computers and other Windows 7 hosts with NLA enabled, and show that they support Network Level Authentication in the about box (RDP 7.1, shell/control version 6.1.7601), so I am certain it is an issue on the host.

Is there a certain service or start-up application on the host that would cause this error? I've gone through the articles I've found and made sure 'credssp' is configured in the registry, really the only change I've made is stopping start-up apps and services but none of them seem to have anything to do with the process.

share|improve this question

migrated from Jun 26 '12 at 18:33

This question came from our site for system and network administrators.

What changes did you make? – Greg Askew Jun 26 '12 at 16:46
Seems like there's a lesson here regarding stopping services and programs "whose purpose [you] do not know." Have you tried undoing what you did to narrow down which program or service seems to be required? – HopelessN00b Jun 26 '12 at 16:55
Revert your system to the previous state using 'System Restore', or some other backup you took. Next time you decide to start disabling things you don't understand, try it first in a VM, or at least take lots of notes, so you know how to reverse your changes. – Zoredache Jun 26 '12 at 18:14
I'm slightly confused. Does it, or does it not, work from Windows 7 and Server 2008 clients? If the problem is only with connecting from Windows XP clients, then you've probably done something wrong in preparing the clients for NLA support. Run mstsc.exe on a client computer, click on the window control button (top left corner) and select "About". One of the lines in that screen will tell you explicitly whether or not NLA is supported. Shell/Control version and RDP version do not matter if the box says NLA is not supported. – Iszi Jun 26 '12 at 19:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.