Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't reproduce what made it happen, but since yesterday, for all the movies I play with VLC - their subtitles (Hebrew) are displayed as question marks.

Any resolution? Way to find the source of the issue?

enter image description here

Here is an excerpt from the subtitles file (*.srt):

1
00:02:04,800 --> 00:02:06,700
...מר דופריין, תאר את

2
00:02:07,700 --> 00:02:11,100
. העימות שהיה לך עם אישתך בלילה שנרצחה

3
00:02:16,600 --> 00:02:17,400
.זה היה מאוד מריר

4
00:02:18,700 --> 00:02:22,000
,היא אמרה שהיא שמחה שידעתי
.שהיא שנאה את כל ההתגנבויות מסביב
share|improve this question
    
Can you check the file in an editor to see what encoding it has (e.g., BOM, Unicode, etc.)? –  Synetech Jun 27 '12 at 3:33
    
How can I check the encoding? I opened it with Notepad and I saw the above. –  Shimmy Jun 27 '12 at 10:28

4 Answers 4

It could be related to the .srt file not being Unicode as superuser (Manos)
or it could be a Region and Language Setting
Region and Language Settings issue in Windows.

Go to [Administrative] Tab > Change System Locale > "Choose wanted language"

Done!

share|improve this answer

If there were any other subtitles in the folder move them to another location. I had the same problem and this solved it.

share|improve this answer

The below solution Worked on a Mac.

  1. Open the .srt file with Firefox web browser (FILE --> Open File...)
  2. Now you should see in the browser window the subtitles text with chinese characters instead of Greek
  3. From VIEW --> Character Encoding... select GREEK ISO encoding. Now magically the text in the browser window is displayed correctly with all the Greek characters
  4. Select ALL text from browser window and COPY --> PASTE to a simple text editor. You should see now the text in greek in the text editor application window.
  5. Save the file as plain text (.txt) in the location that you have the original subtitles.
  6. Rename the .txt file to .srt in order to be recognized from your media player (I use VLC). Just make sure that the whole name of your new .srt file you just created does not conflict with the previous file (you should rename your older file in order to let you rename the new file with the name you want).

That's it, now it should work and display properly the Greek subtitles.

share|improve this answer
1  
The subtitles however are in hebrew ;p –  Journeyman Geek Feb 24 '13 at 11:29

The problem should arise from subtitle character set encoding.

Go to Tools > Preferences (CTRL +P) and select Subtitles & OSD from the left pane. Now change the Default Encoding to Hebrew (Windows-1255) and you're done.

share|improve this answer
    
Nope. didn't help –  Shimmy Jun 26 '12 at 21:44
    
Did you restart VLC? I had the same problem with Turkish letters and the above solution worked for me... –  Mehper C. Palavuzlar Jun 26 '12 at 22:02
    
Yes, I did restart. Didn't help, I'm going crazy, all I wanted is to watch a movie. Now my adventure is to solve the issue and go to bed, movie will be for another time :( –  Shimmy Jun 26 '12 at 22:06
    
Well, I recommend you uninstalling VLC using the free version of Revo Uninstaller, and then reinstalling it. Then change the character encoding to the above setting and try again. –  Mehper C. Palavuzlar Jun 26 '12 at 22:11
2  
OK meanwhile I'm using Media Player classic which displays the subs excellently! –  Shimmy Jun 26 '12 at 22:26

protected by Breakthrough Jun 10 '13 at 20:40

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.