Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to play *.srt subtitles in Windows Media Player?

I've followed the instructions in this, by installing DirectVobSub and renaming the srt file to match the video filename, but the subtitles don't show up, WMP is configured to show subs when available.

share|improve this question
    
It sounds like you're going to a lot of trouble to get it to work. Is there are particular reason that you must use WMP? Can you not use VideoLanClient instead? VLC natively loads .srt files and automatically shows them (you can press a key to turn them off). –  Synetech Jun 26 '12 at 22:41
    
I tried VLC but I face a different problem, anyway, I'm playing it with Media Player Classic and it works perfect. Anyway if there is a solution I'd like to hear about it, so I'll leave this question opened. –  Shimmy Jun 26 '12 at 22:44
    
I would recommend you this technet article and also try out the solution on this Forum thread. However the KMP player is also a good one which works like a champ. –  avirk Jun 29 '12 at 16:34
add comment

3 Answers

What's the file type of the video file you're trying to show subtitles for?

On which version of WMP and Windows? If you're running the 64-bit WMP, you'll need the 64-bit version of DirectVobSub as well.

share|improve this answer
    
Which is gettable via? –  Shimmy Nov 18 '12 at 4:13
    
The x64 version can be downloaded at free-codecs.com/directvobsub_download.htm –  Tim De Baets Nov 21 '12 at 20:26
add comment

Change your subtitle file to exact name as your media name but keep the extension.

Example: 2 files are abc.avi and xyz.srt.

Change xyz.srt to abc.srt.

Now play the abc.avi in Windows Media Player. Right click on the playing windows, check the subtitle setting.

share|improve this answer
1  
They said they already tried that: I've followed the instructions in this, by installing DirectVobSub and renaming the srt file to match the video filename. –  Synetech Jun 28 '12 at 16:22
    
Which codec pack did you install? I'm using K-Lite mega codec pack. –  Nam Phung Jun 28 '12 at 19:42
    
@NamPhung, That's what I installed and it doesn't work for me. –  Shimmy Jun 28 '12 at 23:09
    
So why don't you use Home Cinema Player? –  Nam Phung Jun 29 '12 at 5:36
add comment

Another solution to that problem is Local Subtitles for WMP. It does not brak codecs pipeline.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.