Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can connect with my phone and use the browser as usual. On my laptop it won't connect when using windows 7 while in ubuntu it will connect, but with no internet.

What is going on here and how can I get internet on my laptop ?

[edit]

It's a public wifi hotspot. I can connect with no issues at home. My network asapter is: Atheros AR5B97. And my phone is an iPhone 3G. The wizard's of no help since it asks me to check the router, which I can't since it's a public hostspot.

[edit]

It works on ubuntu. Still doesn't connect on windows.

share|improve this question
    
Need more information. What phone? What laptop? What are the network's settings (802.11 version, encryption used, etc.)? Can your laptop connect to other networks? Also, I'm not sure about Ubuntu, but Windows 7 has built-in troubleshooting wizards. Have you tried those? –  Indrek Jun 27 '12 at 9:21
add comment

2 Answers

up vote 2 down vote accepted

Maybe you have static IP address on your laptop.

Check your adapter configs.

share|improve this answer
    
Nope, it obtains the address. –  Alex Sf. Jun 27 '12 at 9:42
    
When your computer connects to wireless and it does not open page(as you said in ubuntu), it is something about your network adapter configs or firewall. Can you post your routing table here? And can you ping 8.8.8.8 and tell me about the result? Thanks –  Hamed JML Jun 28 '12 at 5:02
    
It works on ubuntu now. I disconnected and reconnected to test the ping, but it works. I'm posting from ubuntu right now. It still doesn't connect on windows though. –  Alex Sf. Jun 29 '12 at 10:31
    
Maybe there is a problem with your driver. Try uninstall it and install it again, after uninstalling reboot your system, I think this will work. Let me know about it. Good Luck –  Hamed JML Jun 30 '12 at 4:09
    
Installed the latest driver. It still won't connect on windows. –  Alex Sf. Jul 2 '12 at 13:28
show 4 more comments

Also, check since it is public, there may be a page that has not shown up, asking you to agree to terms of use. You may not see that and you will connect, but never see anything work. Possibly the iPhone is connecting, but is internet coming through that source? or maybe it is getting 3g too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.