Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Mission to Remote Desktop INTO Windows Server 2012 (standalone).

Situation:

  • Control Panel, System, Remote Settings, Remote Desktop – Allow
  • All firewalls off
  • Connect attempt using a known IP address (ping works ok)
  • Connect Option as a user who has already logged on.

Error message:

Remote Access Cannot Connect
1)  Remote access not enabled
2)  Remote computer turned off
3)  Remote computer not available

Additional info:

  • The Server 2012 can RDC OUT.
  • The machines I use to connect IN are Windows 7 and Windows 8, they will RDC to other machines.
  • I have fair experience of configuring remote desktop.

Question:

Is this a fault of beta software on the 2012 server, or is there a new way of getting RDC to work that I am missing?

share|improve this question
    
Are both on the local network? (I haven't had a chance to test yet, but, this would be the first obvious question). If you don't get an answer in a few hours, I will try to install and test this. –  William Hilsum Jun 27 '12 at 9:28
    
Yes, both on the same subnet. The machine is dual boot. When booted into Server 2008 R2 RDC works. But not in Server 2012. –  Guy Thomas Jun 27 '12 at 13:58
    
Mabe you need to enable "Remote Desktop" for Domain, Private or Public in "Allow apps to communicate throught Windows Firewall" Cheers –  Nebule Mar 14 at 13:28
add comment

10 Answers

I have noticed that sometime enabling remote desktop does not correctly enable the firewall exception for port 3389. Please check whether the appropriate rule is enabled. If it is, try disabling and immediately enabling the firewall. This worked for me on several occasions.

share|improve this answer
    
This worked for me. After installing 2012 R2 Server, and activating Remote desktop, the firewall still blocked inbound communication from Remote Desktop. I had to manually enable the rules for all network profiles to get it work (in my case 2012 R2 is not configured as a domain server, and I think that's why it recognized my LAN as public LAN.) –  Philm Oct 6 '13 at 2:09
1  
I had this problem as well. The Windows Firewall exception that is added by default when RDP is enabled, is only for the private network and in my case, I needed it for the public network. –  ub3rst4r Dec 29 '13 at 19:48
add comment

You'll probably need a CAL (Client Access License) in order to access the Windows Server 2012's resources.

share|improve this answer
add comment

I was in a similar situation to you OP. I had a group policy to enable RDP. I checked that this was applying, and that I could ping the target server. In the 2012 server manager, it said "Remote Desktop: Enabled".

However, after following the steps posted by sushant (cmd > systempropertiesremote) (which can also be reached by other methods e.g. sysdm.cpl) I reached the "Remote" tab of System Properties and saw that "Don't allow remote connections to this computer" radio button was selected. This was clearly the cause of my issue and as expected, selecting "Allow remote connections to this computer" enabled me to mstsc into the server.

I also had another instance where even though RDC was enabled, the firewall port wasn't opened. I now have as standard in any domain I manage two policies, one to enable RDP, and the other to allow it through the firewall.

share|improve this answer
add comment

so I came across a problem while setting a static IP on a windows 2012 VM. When the static IP was set my VM became unresponsive to RDP or RDC. how i fixed it?

  1. go to control panel > Network and Internet > Network And Sharing

  2. top left corner change adapter settings

  3. right click on the network that needs the static IP assigned and select properties

  4. Select internet protocol Version 4 (TCP/IPv4)

  5. select use the following IP address and enter your static IP, subnet mask that is provided and default gateway that is provided

  6. Enter given and preferred DNS

  7. click ok and open command prompt and type : ipconfig /flushDNS

in the above command prompt do not use the Collin and there IS a space after ipconfig

  1. after this is done reset the vm and try to rdp to you vm

  2. you vm is now running on static IP

Jay Ess.

share|improve this answer
add comment

I had the same problem with WINDOWS XP client wich could not connect to Windows 2012 R2 Remote Server.

I solved the problem by unchecking this box on the server: "Allow connections only for computers running Remote Desktop with Network Level Authentication (recomended)".

To find this settings on the Windows 2012 R2 : right click on "My Computer", choose "Properties" then "Remote Settings". In the screen wich will pop-up, you will find that checkbox.

Probably XP does not suport "Network Level Authentication" and when the server requires this, the XP client cannot connect.

share|improve this answer
    
I tried unchecking Allow connections only for computers running Remote desktop with Network Level Authentication, as you suggested, unfortunately it did not solve my problem. –  Guy Thomas Jan 12 at 22:00
add comment

How to enable Remote Desktop on Windows Server 2012:

  1. Move your mouse to bottom right of the screen and you would see a bar, Charm Bar.
  2. Click on the Search button, the one with magnifying glass. See the screenshot below:
  3. Enter CMD in the Apps search text box:
  4. Click on CMD on the left, it will launch the command prompt:
  5. In command prompt window, type SystemPropertiesRemote and hit Enter
  6. The above command would launch the System Properties windows.
  7. Select the appropriate option under Remote Desktop and click OK.
share|improve this answer
    
Please don't just post links to other sites. Include the essential content here. Also, I don't see how this is answering the question stated. –  slhck Jul 18 '12 at 16:10
    
Have you tested your idea on Windows Server 2012? –  Guy Thomas Jul 28 '12 at 20:59
add comment
up vote 0 down vote accepted

After reviewing all the answers and comments, also trawling the internet for similar problems, my conclusion is that it's a file corruption problem on the Windows 2012 Server computer.

Further indications
a) This test machine has given disk problems before.
b) sfc /scannow reveals errors.

share|improve this answer
add comment

Please check whether you have changed the default keyboards.

I had the same problem but as soon as I selected Keyboard - India, which I configured while installing 2012, the system allowed remote desktop connections again.

share|improve this answer
add comment

The issue with the default keyboard certainly is one cause.

On one server, I had removed the US keyboard (that was by default configured during installation), then tried to enable RDP, and it did not work.

Once I re-installed the US keyboard, RDP started working!

share|improve this answer
add comment

I had same problem with both XP and Windows 8 clients... it seemed the server wasn't properly connected to the domain, I rebooted server, logged in as Domain Administrator, and then when I tried to connect using RDP the Win 8 machine worked fine, XP wouldn't due to NLA as above.

share|improve this answer
add comment

protected by Oliver Salzburg Mar 14 at 14:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.