Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows XP professional SP3
Firefox 13.0.1
NoScript Addon 2.4.6

I can't click Javascript links, like for opening a popup window (which I usually don't care about, but this time it was Important :-( ). I mention NoScript as I used to have a button where I could temporarily enable Javascript so the link would work, but with one of the latest updates this seems to be gone.
I have "Block popup windows" unchecked and "Enable Javascript" checked in Options.

How can I get the NoScript button back?

share|improve this question
Do you have the add-ons bar enable? – Nam Phung Jun 27 '12 at 13:02
Press alt and the Tools menu will appear, the add-ons bar option will be in the View option/Toolbars – Nam Phung Jun 27 '12 at 13:09
@Nam - Toolbar is visible at the bottom, but only shows Linkification button. – stevenvh Jun 27 '12 at 13:13
Then you should check the no-script add-ons my no-script is always shown in the add-ons toolbar. Might be something else block your scripts. – Nam Phung Jun 27 '12 at 13:15
@Nam - I'm not sure about that. The add-ons manager says NoScript is enabled, so I presume it will be that that blocks the scripts. It's just not visible. I tried uninstalling and reinstalling. Thanks for your reactions anyway. – stevenvh Jun 27 '12 at 13:28
up vote 0 down vote accepted

I already had tried by re-installing FF, but I didn't want to remove my personal settings, so I kept those. I didn't expect they would cause the problems I had.

But being fed up with them, I just did a complete uninstall, including personal settings (that hurt!), and re-installed. Also re-installed all add-ons, and they now seem to work properly.

So, the NoScript button is where it should be, and also Googlebar and Tab Mix Plus work again (which they didn't, even after re-installing). I presume something must have happened which corrupted personal settings, and which persisted through reconfigurations.

Thanks for the replies.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .