Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question seems to come up a lot (pretty much every time a new version of Chrome is released). Previous answers such as these no longer apply (or don't work for Mac), however:

How do I get the "old style" system print dialog for Chrome on Windows?

Disable Chromes Ctrl+P handling of printing

Sadly, Google seems intent on shoving this broken preview screen down our throats (The thought of someone not wanting to use their nonstandard, feature-poor alternative to a systemwide service is inconceivable to them, apparently), and the "disable" flag no longer seems to exist in recent versions.

Anyone know how to disable it in modern versions of the browser, which no longer include this option under "chrome://flags?" (OS-X specifically?)

share|improve this question

6 Answers 6

up vote 7 down vote accepted

If you want to totally disable it, here's the trick (on Mac of course), type this using a terminal :

defaults write com.google.Chrome DisablePrintPreview -boolean true

Found here : http://www.wptechnology.com/articles/2012/11/13/how-to-remove-this-fg-chrome-print-preview-on-mac/#more-190

Seems that the guy was as angry as me with this incredible feature :p

Hope this help...

Be careful: it totally disables the Chrome print preview... To get it back:

defaults write com.google.Chrome DisablePrintPreview -boolean false
share|improve this answer
    
Changing the accepted answer to this, as it actually fixes the problem, rather than bypasses it. Thanks! –  VeryVito Nov 13 '12 at 19:37

Recent Chrome builds have removed the Print using System Dialog… menu item, so the above method no longer works.

Fortunately, the --disable-print-preview command argument also works on Mac.

Following the instructions in How do I pass command line arguments to Dock items?:

  1. Use Automator, create an Application, add Run Shell Script and replace cat with:

    open -a "Google Chrome" --args --disable-print-preview

  2. Save it as Chrome Normal Print anywhere you like.

  3. Use Get Info to copy Chrome's icon to Chrome Normal Print.

  4. Run Chrome Normal Print instead of Chrome and it will launch Chrome for you with the print dialog fixed.

share|improve this answer

Chrome removed the ability to disable print preview, but on Windows you can still disable it if you modify the application shortcut:

add --disable-print-preview to the end of the "Destination", so it read something like:

"C:\Users\MyUser\AppData\Local\Google\Chrome\Application\chrome.exe" -- disable-print-preview

This will make CTRL+P default to the regular OS-specific print dialog. Ctrl+shift+P also works, for those who can remember the hotkey every time.

Seph

share|improve this answer

You could also swap the shortcuts in System Preferences:

(Or edit the property list directly with defaults write com.google.Chrome NSUserKeyEquivalents -dict-add "Print Using System Dialog..." "@p" "Print..." "~@p")

share|improve this answer
    
THAT'S what I was hoping for! I'd tried to change the shortcut myself earlier, but apparently hadn't typed the name of the command correctly. Thanks for spelling it out. I'm changing my accepted answer to this one, and my mood to happy. Also, charge your keyboard quick! ;) –  VeryVito Jun 28 '12 at 23:01
1  
For the record though... While this controls which screen pop ups for CMD-P, it still leaves us at the mercy of Chrome's preview screen when, for instance, a Web link opens the print dialog. A proper setting within Google Chrome would still be much preferred. –  VeryVito Jul 12 '12 at 12:34
    
Doesn't work any more. "Print using system dialog..." is no longer on the File menu. –  sbwoodside Aug 20 '12 at 18:08
    
It works for me with 21.0.1180.79 / 10.8.0. The menu item is only shown when holding option. If you used defaults, you have to quit and reopen Chrome to apply the changes. –  ؘؘؘ Aug 21 '12 at 1:12

The key combination on OS X for the workaround is command+option+p. Still looking for a way to actually disable it.

share|improve this answer
    
Check Lauri Ranta's comment above. All better now! –  VeryVito Jun 28 '12 at 23:02

The option to disable isn't on the tools screen, and you're right, they did remove the flag. That means that (as of now) it's part of chrome, and getting rid of it would be very difficult, boarder-lining impossible.

You can however just press Shift + Ctrl + P, and you'll automatically bypass the Google Chrome Print Preview dialog. You won't be permanently removing the feature from Chrome, but it should do the trick.

The above key combination works on windows machines. I don't know about OS-X specifically, but I'm sure that key combinations are consistent across nearly all operating systems for programs like Chrome. Refer to the picture for additional information.enter image description here

share|improve this answer
    
That's what I figured. I know it's a little thing, but when every other part of the OS uses CMD-P to call up a usable print dialog, it seems absurd that a single app should force its users to forget everything it knows about the way things work and learn another combination. I guess I'm old and set in my ways, but this one "feature" is enough to lead me to abandon Chrome in favor of the WebKit nightlies. –  VeryVito Jun 27 '12 at 16:15
    
Personally, I love it, why don't you? –  wizlog Jun 27 '12 at 16:50
1  
The default OS X print dialog allows the use of PDF Services which make life crazy easy: In two clicks, I can send Web pages to iBooks for later reading on my iPad (See hints.macworld.com/article.php?story=20100626154406535 for examples), for instance. I have several such services set up to allow me to print Web pages as PDFs to dropbox, iTunes, FTP sites, etc... but thanks to Google's "trust us, you want this slow preview" feature, I find myself staring at an unfamiliar interface and thinking about how much I hate my browser more often than not. –  VeryVito Jun 27 '12 at 17:01
2  
Sure, it's just one more click, but after the 100th time in a day, the blood does start to boil. A simple "Use system default" checkbox would make everything right. Heck, even Adobe figured that one out. –  VeryVito Jun 27 '12 at 17:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.