Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Y560 Lenovo IdeaPad. The laptop is 2 years old and the problem I'm about to describe is present from the first day.

My config: i7 740QM, 4GB RAM, RADEON HD 6570m/5700 1024MB.
Network adapter is Intel WIFI Link 5150.

As may be seen here, the receive bandwidth should be up to 300 Mbps, but the maximum download speed from LAN and using torrents is about 2.4MB/s.

My internet connection is 100Mbps and other laptops in my house have the appropriate download speed: up to 12MB/s. I have tested at my friends house and at my job - the speed remains the same. I have tried all possible configurations I could think of in network settings - nothing helps.

I use Windows 7 and I have had installed different versions (Ultimate, Professional, Home, OEM Home, 64 and 32 bit versions).

Some time ago I searched for the problem and found one or two threads that had the same problem and there were something said about a limitation in firmware that some experienced users have managed to bypass. Updating drivers didn't help me either.

Is there any reliable way to fix this?

share|improve this question
    
What is the make and model of your AP (wireless router) at home? How is your AP configured (radio mode, N rates, security mode, etc.)? –  Spiff Jul 6 '12 at 3:05
    
I was testing it on TP-Link WR1043ND, D-Link Dir-300, and two more routers. Every one except the Dir-300 was N generation. Tested on different security modes as WPA, WPA2, without any security. Hope I answered the question. I'm really pretty sure it's either hardware, either firmware. –  Vlakarados Jul 6 '12 at 7:00
add comment

2 Answers

It seems to me that you have done everything possible, except looking for a hardware problem. So it is a great pity that you have let two years pass-by without using your (now elapsed) warranty, because (on paper) you have an excellent network card.

Some ideas for tests to find out if the problem is hardware or not :

  • Connect an external USB network card capable of high speed, and see if it can do better
  • Boot in Safe Mode With Network and see if the speed improves

These tests might give us some more information on which to continue.

share|improve this answer
    
Thank you, will do the second one and try to do the first one. –  Vlakarados Jul 3 '12 at 13:20
    
Did not help in safe mode. The speed remained the same, looks like I can't find an USB network card to test with, but I'm pretty sure it would make things different.. –  Vlakarados Jul 6 '12 at 7:03
    
This test means that the problem is not some installed product. Since you have already updated the driver to the latest version (did you?), for me this leaves only hardware. I share your feeling that another network card will really make things different, but maybe you should try it anyway. –  harrymc Jul 6 '12 at 20:31
    
Yeah, but as I described in my question, I've seen topics on this one. And I've heard that this limitation is artificial and intentional for some regions, either by the manufacturer, either by retailer. –  Vlakarados Jul 6 '12 at 20:53
    
Have you updated your drivers from the Lenovo Download drivers page? You need at least the BIOS, Chipset and Networking Drivers. Take good backups before doing the BIOS and ensure you have the files for reinstalling the current version before starting. –  harrymc Jul 7 '12 at 7:18
add comment

To get the 300 megabit/sec signaling rate out of 802.11n, you have to have an AP and a client that are both capable of 2 spacial streams, 40MHz-wide channels (HT40), and short guard intervals (short GI).

To use 802.11n rates at all, you must use either No Security or WPA2 (AES-CCMP). WEP and WPA[1] (TKIP) cannot keep up with the data rates of 802.11n, so according to the spec, 802.11n rates should not be used when those older, slower security modes are being used as the unicast cipher. Make sure that your AP was WPA2 (AES) enabled, and that your client is configured to only use AES with that AP. Or turn security off altogether for these tests.

Another rule for 802.11n is that you must have QoS (802.11e, WMM) enabled. If you disable WMM on your AP or client, they may only connect at legacy a/b/g rates.

The client and the AP also need to have good signal strength to each other, and the whole 40MHz-wide channel should be relatively interference-free.

To do a good test of your performance, you need to use a tool like IPerf that is known to use TCP efficiently, and for the sake of clarity, gives speed numbers in megabits (1,000,000's of individual bits), not MebiBytes (1,048,576's of 8-bit bytes). Network I/O is measured in megabits. Disk/File I/O is measured in MebiBytes. Switching back and forth between the two is confusing because sometimes people don't follow the same notation conventions, or forget to convert between mega (10^6) and MeBi (2^20).

You also need to make sure a reasonable TCP receive window size is being used, such as by specifying -w 256K on both your IPerf client and server.

Don't add uncertainty to the measurements by bringing your WAN (broadband Internet) connection into this. Plug a wired Ethernet machine into the LAN port of your AP, and have it act as your other IPerf endpoint.

The rule of thumb for 802.11 overhead is that your TCP throughput in IPerf should be at least 50% of the 802.11 signaling rate that you're getting. So if your software says you're connecting at the 300 megabit/sec rate, you should be able to get 150 megabits/sec of IPerf TCP throughput with appropriately-sized TCP receive windows.

Some variants of your Intel 5150 were asymmetric; they could only transmit using one spacial stream, meaning that much of the time their transmit speed would be only half of their receive speed. This invalidates using Bittorrent as your performance test, because I believe Bittorrent has a fairness algorithm that limits your download speed to match your upload speed, or something like that. Also, Bittorrent has a fair amount of overhead from opening up lots of separate TCP connections between peers.

I don't know why you mentioned testing against a D-Link DIR-300. As you noted, that's not even an N-capable AP. Getting 20 megabits/sec (I'm translating that from your note of "2.4MB/s") is decent for 802.11g rates. It indicates that your client is probably hovering around the 36 megabit/sec signaling rates most of the time, which is decent depending on radio conditions.

So, putting this all together:

  1. Put your TP-Link WR1043ND in HT40 (it may call it 20/40) mode, pick a control and extension channel that you can see (from a tool like inSSIDer) is clean, make sure short GI is enabled (if it even exposes that option). Turn off security for this test. Make sure QoS (802.11e, WMM) is enabled.
  2. Plug a wired Ethernet machine into the LAN port.
  3. Put your Y560 about 3 meters away from your AP (too close can overload the radios and cause poor performance), and turn off Bluetooth. Note what 802.11 signaling rate it says it's getting. If it doesn't say 300 megabits/sec or at least 270 megabits/sec, then you can probably skip the rest. ALSO check to see what the TP-Link WR1043ND reports as the signaling rate it's using when talking to the Y560. Again, if it doesn't say 300 or 270, then you can probably skip the rest, because your two devices just aren't using the data rates they're supposed to be using. You might want to check in advanced driver settings for your 5150 driver if it says that you've got HT40 enabled for the 2.4GHz band.
  4. On your Y560, run iperf -w 256K -s. IPerf by default sends traffic from the client to the server. You want to test how fast your Y560 can receive, so you want it to be the server.
  5. On your wired Ethernet machine, run iperf -w 256K -c $Y560IPADDR, where $Y560IPADDR is the IPv4 address of your Y560.

See what the results are (in megabits/sec).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.