Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a server at work that I use to host a blog, wiki, and a few other applications that I often use from home. Today I tried to access the server from my laptop (Macbook, OS 10.5.8, Firefox 12.0) and I started seeing some strange behavior. When I requested the page myserver.edu/mywiki, I got a Google 404 error page. I tried a few other pages on the server (that I could remember off the top of my head), but I got the same result. When I tried the server root index page (myserver.edu) I got completely redirected to the Google home page.

In the last few days, we've set up new internet service at our house, so I thought something might be wrong there. But I was able to see the page correctly from our desktop (on the same network). So then I thought there might be some strange browser caching issue, and I cleared the entire cache history, but that didn't work either. I tried different browsers and even a different account on my laptop, but all have the same problem.

There is some system-wide issue that is causing my laptop to think that myserver.edu is google.com. I checked the /private/etc/hosts file--I didn't see anything out of the ordinary, although I am not sure what to expect either. Any thoughts as to what might be causing this?

share|improve this question
up vote 1 down vote accepted

What about the dns server configured in your laptop? try switching to Google's dns servers: 8.8.8.8 and 8.8.4.4; or openDNS: 208.67.222.222 and 208.67.220.220.

share|improve this answer
    
Well, I didn't even have to change DNS servers--I just flushed my DNS cache (dscacheutile -flushcache for OS 10.5) and the problem went away. Thanks! – Daniel Standage Jun 28 '12 at 0:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .