Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Comcast business Internet here. It gives me 5 static IPs.

Most of the machines in my house connect to a router like every other household. It has a 192.168.117.x subnet, DHCP Server, etc. and all is well. However, I have a second machine on MY desk that has a life Internet IP. Up until yesterday, this machine was running XP Pro. The primary NIC was manually set to 192.168.117.241 with no gateway, and the secondary NIC was manually set to 173.x.x.171 with a gateway of 173.x.x.174. This worked just fine for years.

Yesterday I replaced that XP machine with a brand new Windows 7 x64 box. Again, I configured it the same way. The onboard NIC was given a static 192.168.117.x address with no gateway, and the secondary NIC was given a live Internet IP address with the proper router, etc.

2 Problems. First is that the internal network (192.168.117.x) is listed as a public network because there's no gateway, so that means no homegroup, no file sharing, none of that. And I can't change it from what I'm reading...

The second is that the machine reports the "router" ip address as it's address, and not the address that it's supposed to. I'm ready to tear my hair out over this. Any ideas?

share|improve this question
    
Update: I figured out the second problem. Sorta. It had something to do with the particular IP I was trying to use and it's interaction with the comcast gateway box. I changed to a different Internet IP and it works fine. Strange... ******************************** I also managed to use some kind of hack that upgraded it from a public network to a work network. I still have no homegroup (which I don't care about anyway), but I do have file sharing, which was the important thing. I wish I could fix it properly, though. –  Eric Jun 28 '12 at 2:50

1 Answer 1

This is really two questions? Perhaps best asked as two questions.

This first issue is easy to resolve. There is no reason why your local IP shouldn't have a gateway, it should be set to the routers IP address. You can either change your router configuration so that it provides itself as the default gateway in the DHCP configuration. Or you can manually add the router as the gateway in the network configuration in Windows.

For your other issue, does your router support multiple IP addresses on the Internet side? If so, there is a much better way of setting things up. Why not give the second NIC a fixed address via DHCP and set the router to make the 2nd NIC in the DMZ (AKA a "virtual server")? Most routers will let you designate an internal IP address as effectively connected straight to the Internet. The settings are normally referred to under the heading DMZ. This lets the router do some basic security stuff without getting in the way. My old Draytek router would do this but my current Billion doesn't.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.