Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ASUS ENGT440/DI1GD5 video adapter which has three output ports: D-Sub (HD-15), DVI and HDMI. I am using both the D-Sub and DVI ports, but my main monitor is connected to the DVI output. Everything works fine except for which monitor is designated the console during boot.

The video adapter seems to prefer the D-Sub output for the console. When both the VGA and DVI monitors are connected, then the VGA monitor always becomes the console which displays the motherboard logo, POST information and booting progress. When only the DVI monitor is connected, then it becomes the console as desired.

How do I make the video adapter always use the DVI output (instead of the VGA port) for the console while booting?

share|improve this question
    
Windows or Linux? –  Diogo Jun 28 '12 at 11:47
    
Either system is fine, I have both. I haven't mentioned it in the question because I thought that this is beyond installed systems. –  Igor Zinov'yev Jun 28 '12 at 12:42
1  
The BIOS is software, so it displays the logo in graphics mode, and then switches the video mode to text for the POST data. Reading between the lines, you seem to be asking the wrong question. "Text mode" is irrelevant. Seems like the video adapter defaults to the VGA (aka D-sub or HD-15) port for the console when a VGA monitor is connected. The DVI port is the console only if there is no VGA monitor connected. You want the console on the DVI port even if the VGA is connected. Is that the issue you want to solve? –  sawdust Jun 29 '12 at 8:46
1  
LOL, someone had the exact opposite problem as you: forums.gentoo.org/viewtopic-p-6795912.html . Some responders mention a "display auto-detect", and one of my PC's BIOS does have such an option (right after a SLI option), but both options are grey'd out. I have no idea what "display auto-detect" actually does. BTW I was able to duplicate your symptoms with a GeForce 8400. –  sawdust Jun 30 '12 at 5:14
1  
@IgorZinov'yev: Yes, usually the black one is slower than the blue one: ...unless in crossfire mode the black will run at 4X and the blue will run at 16X. –  rishimaharaj Jul 26 '12 at 15:46
show 7 more comments

2 Answers

up vote 1 down vote accepted
+50

kinokijuf is correct by saying:

The BIOS does not know anything about the graphic card parameters

Usually in the BIOS you can set where on the Motherboard the default display goes to: OnBoard, PCI, PEG (PCI Express Graphics), etc. It's then up to the graphics card to display whatever based on it's own priority settings.

Possible workaround (assuming you are currently plugging VGA from card to VGA in monitor2 and DVI from card to DVI in Monitor1):

Since VGA is taking priority over the DVI slot, you can purchase two adapters:

  • DVI (female) > VGA (male)
  • VGA (female) > DVI (male)

These types of adapters can be found on Google here, and look like this:

DVI > VGA VGA > DVI

  • Plug the VGA cord into your card, connect the VGA > DVI adapter, and plug the DVI into Monitor1. Then plug the DVI cord into your card, connect the DVI > VGA adapter, and plug the VGA into Monitor2.

This might degrade the image quality, so I'd recommend using the DVI/HDMI outputs instead of the VGA. If you do end up going the DVI/HDMI route, most likely the HDMI will take priority over the DVI.

share|improve this answer
    
Wow, I haven't thought about using adapters, although I think I will be better off using HDMI, you're right about that. I will give it a try, thanks! –  Igor Zinov'yev Jul 26 '12 at 18:55
add comment

It is impossible. The BIOS does not know anything about the graphic card parameters (display resolution and count, etc.). Depending on the model, it could display the POST on both monitors or either. The question is, what are you really trying to do?

share|improve this answer
    
Are you absolutely positive that it's impossible? Isn't there some way to tweak the graphic card preferences? –  Igor Zinov'yev Jul 26 '12 at 18:56
    
@Igor tell me your real problem, not your attempted solution. –  kinokijuf Jul 27 '12 at 9:15
    
As stated in the question, my problem is that the card chooses the D-Sub port for console display output instead of the DVI port when both have displays connected to them. I was thinking that there was some way to set the card's internal preferences some way. You say that it's impossible, and I'm curious about how you know what. –  Igor Zinov'yev Jul 31 '12 at 13:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.