Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got a new flash drive (Corsair Flash Voyager 32GB). I tried to install live Chromium OS on it but I messed something up and decided to reformat it. The formatter froze and I canceled it. Now neither my Windows 7 Dell nor my Apple OS X Lion can recognize my flash drive when I plug it in (it does not show up anywhere). How can I force it to show up so I can reformat it?

share|improve this question
Try using a Gparted Live CD – VBwhatnow Jun 29 '12 at 7:32
May be the format froze because the USB stick went defect? – Robert Jun 29 '12 at 8:38
up vote 1 down vote accepted

Return it and get a new one. Works every time.

share|improve this answer

I got a usb flash drive which was unrecognized by my pc. I followed following steps to make it recognized.

  1. Right click on Computer icon in desktop.
  2. Go for manage
  3. In that option use disk management. You can see available disk in your pc. Your flash drive is seen in that as "disk 1" (note disk 0 is your primary harddrive)
  4. Change the drive letter if possible.
  5. If you cant right click and use "delete drive" option.
  6. Then you can see that Drive as "UNALLOTED"
  7. Right click on it and go for "New simple Volume"
  8. Follow the wizard as it instructed. It requires formatting.
  9. Now it is your Flash Drive Flashing on your desktop.

Enjoy. All the best.

share|improve this answer

You can try to use DISKPART utility in Windows 7.

When you enter that utility, first write LIST DISK. That will give you list of all recognized drives including USB. Remember number (e.g. 9). Than you can execute


That should give you clean slate.

P.S. Do be careful to select correct disk number. If you select wrong number, you will format wrong disk.

share|improve this answer
Just tried list disk, only my hard drive shows up. – Matt Jun 29 '12 at 7:40
That usually means that something has gone on hardware level. – Josip Medved Jun 30 '12 at 1:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .