Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ATT wireless modem and a LinkSys Router with DD-WRT v24 sp1 installed. I went through the instructions on this page and got to the point that the DD-WRT router can talk with the modem. My goal is to use the LinkSys as a wireless repeater, but for now, while I'm testing, I'm connecting to the LinkSys router via wire.

From the DD-WRT interface, if I go to Administration -> Commands and run a "ping google.com" I get a reply, so that tells me the LinkSys and the modem are talking. However, if I try to ping google from the computer, while connected to DD-WRT via wire, I get time-outs.

I followed all the recommendations / steps on the WLAN repeater page. Any idea what else I could try? Thank you!

EDIT:

The configuration is something like this:

ATT modem:
  default gateway: 192.168.1.254
|
(wireless connection)
|
LinkSys WRT54GL v1.1 with DD-WRT v24 sp1
|
(wired connection)
[my computer]
  IP: 192.168.2.128
  default gateway: 192.168.2.1 (LinkSys's IP)
share|improve this question
    
Just to verify, when you ping google.com does it actually reach an external IP? –  hyperslug Sep 20 '09 at 22:33
    
Also check if the wired computer receives a correct DHCP assigned IP. –  hyperslug Sep 20 '09 at 22:43
    
1) If I ping from the computer that's connected to DD-WRT router all the pings time out. Not sure what you mean with "reach an external IP." If I don't get a reply from ping I guess it doesn't, right? If I ping from DD-WRT interface it works (ping, i.e.) 2) The wireless router is on a 192.168.1.x subnet, I assigned a 192.168.2.x subnet for the DD-WRT router. When connected to DD-WRT I get a correct (I say) 192.168.2.108 (usually) IP. Thanks. –  pbz Sep 20 '09 at 23:40
    
check MAC filtering settings and make sure your NIC's MAC is in the allow list. –  John T Sep 21 '09 at 0:29
    
@John: I didn't see any MAC filtering options on DD-WRT that would be configured. Is there a specific place you're thinking about? –  pbz Sep 21 '09 at 0:58
show 5 more comments

2 Answers

up vote 2 down vote accepted

pbz found that configuring DD-WRT as a Repeater Bridge instead of Repeater allowed him to access the internet when connected to his DD-WRT device via ethernet cable.

Wireless -> Basic Settings -> Wireless Mode -> Repeater Bridge

In contrast to Repeater, Repeater Bridge allows for connecting clients to be on the same subnet, in his case 192.168.1.x. Here is a comparison matrix between WDS vs Repeater vs Repeater Bridge features.

share|improve this answer
    
One interesting problem, is that after switching to RB mode, even when connected via wire, the gateway became the ATT modem. The bridge became invisible as it's replicating the original router -- at least that's my understanding. So... how can I access the DD-WRT now? :) And is there a way to know, when connecting wirelessly, that I'm connecting to the ATT modem or the DD-WRT router? It works, I'm not complaining, just trying to understand. Thanks for all your help!!! –  pbz Sep 21 '09 at 2:57
1  
Yeah? You sure the DD-WRT/Linksys doesn't get an IP? Do you have an IP scanning tool, like Angry IP Scanner angryziber.com/ipscan/ipscan.exe to see if you can find it? –  hyperslug Sep 21 '09 at 3:43
add comment

i know its late to answer this post but incase someone else reads it later ill post to get access to the ddwrt just change the ip on either the dd-wrt seperate from the original group range ie. router is 192.168.0.1 ddwrt is 192.168.1.1 or pull up your original router and see what clients are connected and find the ip given for the ddwrt =D

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.