Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am facing a very strange issue with my keyboard and I cant find a fix after googling on keyboard issues. Today when I started my laptop after hibernation, two keys seem to have got remapped at some level.

  1. When I press the spacebar 'Alt' gets pressed instead. (I can see 'Alt' getting pressed in the Windows On-Screen keyboard).

  2. Pressing 'c' produces the © symbol (and pressing Shift+c produces ¢). Here I see 'AltGr' getting pressed in the On-Screen keyboard.

Also pressing 'AltGr' prints ©. I used KeyTweak but it shows that the Spacebar is correctly mapped to the space. So I'm not sure where exactly the problem lies.

Any hints?

share|improve this question
    
Have you rebooted? Not sleep, hibernate... restart. –  lornix Jun 30 '12 at 6:27
    
Hi @lornix , yes I re-booted my laptop.. Then went ariund resetting a couple the default language, but the issue didn't go away. After an hour the keyboard returned to normal. Which is great but very confusing.. :/ Not sure how to fix it if it happens again. Thanks. –  Kent Pawar Jun 30 '12 at 19:39
    
Hmmm, so this is basically a Phase-of-the-Moon issue. {Grin} I'm glad you got it resolved, sad because we still don't know how it got that way. {evil grin} Do it again.... –  lornix Jun 30 '12 at 19:40
    
Ya wish we could figure out the cause of this sudden change in keyboard behavior.. Well the last 'change' I can remember is the Windows 7 software update that happened prior to the hibernation.. Well thanks for your inputs @lornix .. [Hey excuse my typo's in the comment above.. You replied before i could edit it.. {Grin} ] –  Kent Pawar Jun 30 '12 at 20:18
    
With a Windows update involved, the best we can do is probably, "Sorry Officer, it was like that when we got here". Don't worry though... if it happens again... we know it can be fixed. (don't know HOW, but it CAN be done. Yay!) –  lornix Jun 30 '12 at 20:21
add comment

2 Answers

I had a similar issue where my laptop keys stopped working one by one after re-installing windows 7 with SP1 on my Toshiba laptop. This included all the Fn key functions. The keyboard had worked fine for a day after the reinstall. The issue started all of a sudden while working on the laptop.

Checks performed Checked typing in different programs, safe mode, using Ubuntu as Operating system. Tried all the software and driver update that everyone suggested on forums. Even thought of replacing keyboard as thought it's life is over. Spent a day trying different options. Even removed keys from laptop and cleaned underneath. But to no avail.

However, the most unlikely solution I came across was someone mentioning damaged ribbon cable that connects laptop keyboard to motherboard. I unscrewed the keyboard with cable still attached to motherboard. The cable was folded like a V from the keyboard to the motherboard, which I straighten when I pulled the keyboard towards the touchpad. All the keys that didn't work now started working including the Fn keys.

So for me the problem was the folded ribbon cable. I guess because of years of being bent (like paper) the wires inside the ribbon are giving up. (and also I have removed the keyboard countless time over the years while dismantling the laptop thus straining the cable while putting it back to the motherboard). I guess the bending of cable was causing issues with matrix of the ribbon cable. Sometimes when I pressed a key, three characters use to appear. Pressing O showed French characters. It looks like it was a coincidence that the keys stopped working just around the time of reinstalling Windows 7.

SOLUTION I folded the ribbon cable other way round without flattening the cable like paper so that the original bend straightens.

I missed the basics of troubleshooting - to look at the cable connections before looking for other solutions. Looking at the 'Fn only' issue people are having, it seems like a driver/software issue. However, for issue with some keys, it looks like it's a ribbon issue. It has fixed my issue at least for now. I am typing with the same keyboard :)

share|improve this answer
add comment
up vote 0 down vote accepted

Well if you have encountered a similar issue (probably caused after a Win7 update).. Don't fret! Hopefully a PC restart should do the trick.. Note that my Keyboard configuration in 'Control Panel' > 'Clock, Language, and Region' was correctly set to the default all along.

But note that after a restart and leaving my PC on for a while, the keys then started acting normal..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.