Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been having some issues with my RAID setup recently on my headless Ubuntu 10.04 server which means one of my mount requests is failing on bootup. Clearly I need to fix the RAID issue, but this machine is in my loft and having to crawl up there with a keyboard just so I can hit S a few times is extremely irritating.

The exact message is as follows:

The disk drive for /drv/photos is not ready yet or not present

Continue to wait; or Press S to skip mounting or M for manual recovery

I'd still like Ubuntu to try and mount it, but is there any way to tell it not to wait for the device?

share|improve this question
Have a look at this:… You might have to add nobootwait – Onitlikesonic Mar 20 '13 at 9:33

Find out in which partition you facing error.. like it shows /partition name.. remember that partition and in your terminal type this,

gksu gedit /etc/fstab 

Locate the line showing your partition where getting mount error... and add to the options section the following:


like this,

UUID=XXXXX    /    partition    nobootwait,etc ...
share|improve this answer

Admittedly sub-optimal as a solution but you could always try moving that mount command to the /etc/rc.local file so it's not a locking operation.

share|improve this answer
In what way is that sub-optimal? – Jon Cage Jul 5 '12 at 12:30
@JonCage - it's sub-optimal because mounts are normally handled through fstab - putting boot-time mount commands in random places makes it harder to understand what your system is doing at startup. – Michael Kohne Feb 18 at 13:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .