Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought a Creative x-fi HD usb sound card, with the intent of using the SPDIF optical input to play audio from my PS3 games console through my Computer.

I have connected the sound card to my pc through the usb connection, and installed the latest drivers from Creative's website. I have connected my PS3 to the optical input on the back of the sound card, and ensured that the ps3 is outputting audio through the optical connector (I have tested this through another device, and am sure it works fine).

In windows, I have set the default to recording device to USB soundblaster HD SPDIF-In, and made sure to enable it. After doing this, the recording device fails to receive a signal from the PS3.

Interestingly, I tested the other inputs on the soundcard with an external mp3 player, and the line-in also doesn't work, but the phono-in does.

I also had exactly the same problem with my old Creative Audigy 2 Platinum EX, which is why I replaced it with the x-fi HD.

If it is relevant, my intended playback device is a set of Bose Companion 5 usb speakers, although setting the playback device to the creative x-fi (hence bypassing the Bose speakers) didn't resolve the issue either.

I'm also running Windows 7 64bit home premium on a Gigabyte z68AP-D3 motherboard, with an intel i5 2500k processor and an AMD 6950 GPU.

Does anybody know of a solution to this, or whether it is a hardware issue with the soundcard?

share|improve this question

1 Answer 1

I've also bought a Sound Blaster X-Fi HD USB soundcard and experienced the same problem with the 'SPDIF optical in'. Here is my sollution: As You don't have input-selector switch on the device, you have to switch to the 'optical in' input trough software way. You have to install Sound Blaster "Entertainment Console" tool (CD provided). In the 'Mixer' menu you will be able to switch on the 'optical in' input (because the default factory setting for the 'optical in' is unfortunately: 'off') When you enable it you will be able to use any optical device on the sound card's SPDIF input. I hope I could help :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.