Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm Trying to install Ubuntu 12.04 on my computer. It had an old copy of Windows 7 on it I tried to reformat the hard drive for a fresh install of Ubuntu but I think I messed up the partitions in some way that prevents it from fully loading.

I'm able to complete the install fine and use guided partitioning so it should be happy but when it gets about 90% through at the part that ejects the cd and restarts the system it fails. After ejecting the CD and restarting it just loads up the bios lenovo splash screen then purple then black. I can hear a sound from my speakers like some notification sound but there is no text on my screen.

I've since gone back in under Rescue System to try and reconfigure the partitions hoping that it will fix it and i've tried several combinations. Currently it's

SCST1 (0,0,0) (sda) - 500.1 GB ATA WDC WD5000AAkKX-0
#1 100.0 MB     K      biosgrub
#2 494.1 GB   B K      ext4            /
#3 5.9 GB       F      swap            swap
   8.2 kb              FREE SPACE

I'm not sure if I need to set the ext4 to contain the boot flag but if I don't include at least one partition with the boot flag enabled it complains saying that "The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partitionshould be marked for use as an "EFI boot Partition" and should be at least 35 MB in size. Note that this is not hte same as a partition mounted on /boot"

Like I said it seems to have installed all of the actual data from the CD it's just not properly booting for some reason

share|improve this question
    
(1) reinstall, (2) burn another CD and reinstall, (3) take a video and ask again –  Alvin Wong Jul 1 '12 at 3:04
    
The problem can be corrupted CD, wrong driver installed or something else, but probably not the partition table. –  Alvin Wong Jul 1 '12 at 3:06
    
take a video? Not sure if you mean watch a video because it takes so long or actually record my steps because there are a thousand things that could be causing the problem. –  Randnum Jul 1 '12 at 3:10
    
I mean take a video of the startup sequence –  Alvin Wong Jul 1 '12 at 3:14
    
I recommend you to use some Partitioning program, delete all on your hard, and format it, then write a new Ubuntu(Although I prefer to install from Cool Disk(Flash Disk)), Install and enjoy the freedom. –  Hamed JML Jul 1 '12 at 4:18
show 1 more comment

1 Answer 1

up vote 1 down vote accepted

IMO don't waste your time trying to fix a failed installation - install the OS again.

If the regular install is not working, try the alternate install image (text-based).

share|improve this answer
    
I'm installing without an internet connection I wonder if that is somehow preventing the graphical installer? otherwise it looks like everyone is just saying it's my installation CD and to just download and try again. Will do! –  Randnum Jul 1 '12 at 3:15
    
@Randnum yeah, i've tried troubleshooting failed installs a few times.. redownloading has been my solution in the end every time. Also, the text-based installer seems more successful in those situations, tbh i don't know why. –  trideceth12 Jul 1 '12 at 4:22
    
I think it could be something to do with the video driver, it must be trying to load a graphical screen after the initial setup and I remove the CD. This is where it is failing. I have tried the alternative CD though and it took me to the same screen...is there a way to load the drivers that I need during set up? –  Randnum Jul 1 '12 at 18:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.