Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have file sharing and remote desktop and all that crap disabled in Windows. Do I have to enable all these crap Windows services to access files through FreeNAS?

What Windows Services are absolutely mandatory to be running in order to access files?

share|improve this question
    
WORKGROUP or Domain? –  Logman Jul 1 '12 at 13:37
    
Your windows computer can not see your FreeNas box? RDP and file sharing is not needed to access files stored on a NAS box. They are only needed to access your windows computer/files. –  Logman Jul 1 '12 at 13:44
    
My Windows computer can see my FreeNAS computer just fine. I am able to log into the Web UI for FreeNAS with no issues. –  techaddict Jul 2 '12 at 5:57
    
@techaddict: If you enable the CIFS service in FreeNAS, are you not able to access files via \\FREENAS (or whatever name you are using)? Do you have the Workstation service enabled? –  James Jul 4 '12 at 11:20

1 Answer 1

If you just want to access the files on the NAS without enabling any Windows service, the easiest was should be to open your web browser and put ftp://ip-of-your-nas/ into the address bar (replace "ip-of-your-nas" with the IP address of your NAS). Or, alternatively, use a more comfortable FTP client as e.g. FileZilla. For this, FTP must be enabled on your NAS -- on most NAS systems this is the case, AFAIK.

share|improve this answer
    
or just go to the RUN dialog from the start menu and type the IP Address or the FReeNAS computer name \\ip-of-your-nas or \\computername. If it fails try using the ping command the prompt. –  Logman Jul 1 '12 at 19:09
    
Unfortunately, this "ftp" method does not work. I get the "This webpage is not available" error in Google Chrome. Perhaps it is not as simple as merely entering this address, but rather perhaps there is some configuring that needs done. Or, perhaps these instructions are entirely invalid. –  techaddict Jul 2 '12 at 6:31
    
Make sure that 1) your NAS has FTP enabled and 2) you entered the correct address. If you fail with one of these two, it cannot work. Same applies to having a firewall between those two machines: here you must ensure it lets through ports 20 and 21 (both needed by FTP, one for control and one for data). –  Izzy Jul 2 '12 at 6:36
    
Both those things and still "The webpage is not available." I have no firewall. So you're saying that the FTP option is broken on FreeNAS? When will they fix it? –  techaddict Jul 2 '12 at 7:39
    
So you're saying both conditions are met (FTP service running on the NAS, havin entered the correct address) and still no connection? Have you tried with a different FTP client (e.g. FileZilla or the command-line ftp 192.168.1.123 (of course with the correct IP))? An also likely error is the browser replacing "name"; by "ftp.name.com/";, which is one reason I'm asking for the alternative client). If your FTP service is up and running, and no firewall between, you should be able to connect -- or something really weird is happening. –  Izzy Jul 2 '12 at 8:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.