Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 4 USB com port devices where three of them work and only one dosn't. I have unplugged and replugged in, un-installed driver re-installed. I have also tested the device in a different laptop which works.

Any ideas on what I can check or configure?

My only last resort is to re-install the OS.

Thanks in advance.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Try removing the drivers from the system in safe mode... then reboot into normal mode, and reinstall as appropriate.

Boot into safe mode, right click on my computer, properties, hardware, devices, ... it should be in there under ports or com/lpt or something... (with the usb com ports removed!), right click and uninstall each one. Then reboot and reinstall the drivers if needed.

share|improve this answer
add comment

To separate between a hardware or software problem you could simply boot a Linux live system like Knoppix. This is much easier than reinstalling the OS (and thus probably making the current, fully working system unusable) just to find out it is a hardware fault.

These USB to RS-232 adapters are often of poor quality and lack compliance to voltage levels and/or are missing some functionality because there are only 5 or even 3 wires used. So some really bad adapters will only work with software handshake on devices that are tolerant to missing negative voltages.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.