Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't connect to the wireless network from Windows 7 (Bootcamp) on my MacBook Pro (Mid-2010), despite that my HTC Desire (Android) works just fine with it. Windows doesn't ask me for the key and just reports "Windows was unable to connect to this network".

I have tried the following:

  • Updating the driver for my wireless adapter from Microsoft servers and from Bootcamp CD. Windows reported that the drivers are up-to-date. Device manager lists my device as "Broadcom 802.11n Network Adapter"
  • Deleting all known wireless networks and creating wireless connection manually. The connection is registered, but windows won't connect to it (not even give the message given above)
  • Using Windows Network Troubleshooter
  • Rebooting :)

None of these helped. Please advice what I can do to diagnose and solve the problem. Thank you.

P.S. Changing router settings is very undesirable since it belongs to the apartment owner and other people are using it with no problems. If someone is familiar with this - router is from Internet provider Alice (München, Germany).

share|improve this question
does the network connection between Win7 and your Mac work fine? Can ping each other? Share? etc... and will it work "wired"? – Logman Jul 1 '12 at 16:07
Both Win7 and Mac are installed on the same computer, so there can't be any connection between them as they can't be booted at the same time. I couldn't try it wired since I didn't have a cable, but I have found a solution to the problem (see below). – Sergiy Byelozyorov Jul 8 '12 at 10:47

Is there an open unsecured wireless network within range that windows might latch onto? I've had systems grab my neighbor's unsecured (stock!) netgear unit which is just barely in range... it thinks 'free wireless!!', but it can't talk to the router to negotiate the connection.

Sounds stupid, but this is one of those 'phase of the moon' type things... try rebooting the router. Just unplug it, count to ten in Swahili, then plug it back in.... Mine does this occasionally where it doesn't want to talk to anyone new. Yes, your Mac side of Bootcamp can connect, but Windows has a different 'flavor' to the router. (hopefully, that made sense)

Just point to a corner of the apartment... yell loudly "Look! It's Elvis/Stalin/E.T./StayPuft Man!!!" And while they're gawking, reboot the router...

Honest... it works. (the reboot, AND the Look! thing...)

share|improve this answer
Nice approach to rebooting a router (Look! thing) :) – Sergiy Byelozyorov Jul 8 '12 at 10:45
up vote 0 down vote accepted

Sorry for my stupidity. It was just a wrong security key - windows didn't report that it was incorrect but silently failed the connection. When I tried the same on Mac OS, it has reported the error correctly.

In details that is how it worked for me:

  1. Right click on the network icon in the tray and select Open Network and Sharing Center
  2. Select Manage wireless networks on the left
  3. Click Add in the toolbar
  4. Select Manually create a network profile
  5. Type SSID (name) of your network
  6. Select security and encryption type (if the combination you selected won't work - you can change it later)
  7. Type into your security key (make sure it's correct).
  8. Click Next and Close

Now click once on the tray icon and see if the connection is shown with red cross next to it. Typically that means that you have selected the wrong security/encryption type at step 6. Just right click the connection and select Properties. There at Security tab you can change security and encryption types. Try different combinations until you'll get rid of the red cross. Then just click on the connection and select Connect. It should work now.

Good luck!

P.S. If there is a demand to show this in pictures - please write in comments and I'll create screenshots.

share|improve this answer
Yeah, Windows is weird that way... mistype the key... it SAYS it's connected, but it LIES!!! LIES!!! Mac, Linux, Android, they all say "Bad Key, Try again"... But Windows LIES! I'm glad you figured it out. Of course, admitting that you fat-fingered the key is a good thing. Good for your soul, or karma, or such. We'll laugh, but it's a sympathetic laugh, because we've ALL done it. Of course, no one mentioned the possibility of mistyping the key... because would be like calling you stupid in public. Wouldn't want to do that, that's mean. Glad you got it working. – lornix Jul 8 '12 at 11:34

Windows 7 prefers to use WPA2-AES encryption. Check your modem/router settings to make sure it is using the correct encryption.

share|improve this answer
I don't see how this would plausibly be the cause of the problem. – bwDraco Sep 29 '12 at 19:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .