Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Windows 7 formatting HD

I'm trying to install Windows 7 x86 or x64 but i get an error when it sticks to a certain percentage. The error code is 0x8007045D on other blogs they say that my installation disk is the problem. But i tried several disks and ISO files, also tried installing form USB.

So what could be the problem?

thx,

(It's a packard bell laptop, and i'm using a .iso copy burnt to dvd and a bootable usb. The dvd and usb i'm using worked on my other pc's. Also i can't install linux (also stops at the install))

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Oliver Salzburg, Randolph West, Diogo, Nifle Jul 2 '12 at 7:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

Sounds like a hardware failure. Have you tried if you can boot a Linux live system like Knoppix? Knoppix has also an option to run a memory test on the computer by typing memtest at the boot prompt. Also run that, especially if the live system also gets stuck.

If the live system works and there are no memory errors, the hard disk might be the problem. Run sudo smartctl -a /dev/sda (assuming there is only one HDD present, so sda should be correct) from Knoppix (or any other linux system that has smartmontools available) and see if there are critical S.M.A.R.T. values. You can also run a test using sudo smartctl -t short /dev/sda or sudo smartctl -t long /dev/sda and check the result with sudo smartctl -a /dev/sda again after the test completes.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.