Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 32 bit, up to date, Intel i7 860. (For some reason the company runs 32bit Windows everywhere.) I tried to update all motherboard drivers etc. as far as possible.

I have a performance issue with a machine which appears in connection with multithreading (or so I think).

As an example (and where I most often see it, but it appears on other programs as well): ProteoWizard is a file conversion tool for mass spectrometry files. I can add a list of files and it will attempt to process up to 8 files in parallel (quadcore x 2 threads/core). If I choose 1 to 6 files, I start the process and it goes straight through. If I have >=7 files in the queue, conversion goes to ~20%, then gets stuck for 15 seconds, then continues again, always in "chunks" of a few % before getting stuck again.

During the time the process is stuck, CPU is at 1%. RAM is not limiting, it is maybe at 70% or so and not going up.

I don't get the same problem on other, even slower machines.

The computer gets also stuck at 1% CPU doing nothing on other occasions, but for multithreading it is most frequent.

Where should I look for the problem?

System Information screenshot showing problem

Edit: See this screenshot from Process Explorer; nothing is at the limits. CPU is flat, RAM is constant at e.g. 60%, I/O is flat, GPU is flat, network is flat, disk is flat. You see exactly how far the process ran fine and where it grinds to a halt. At first, 2 of the 8 threads continue working, then they die down too.

share|improve this question
    
Update: I ran the Windows memory check and the memory seems to be fine. To me, it "feels" like there is some conflict where everything starts waiting for something the system should do and it doesn't... –  meow Jul 2 '12 at 9:07
    
Any Temperature problem? –  M'vy Jul 2 '12 at 9:09
    
Hm... I don't know. With HWMonitor I see the CPU temp constantly around 45°C, but the max shows very high numbers ~90-120°C even when I clear the max... However I never see high numbers in for the current temperature. Could it be that the CPU creates very short temperature spikes and immediately "shuts itself down" again? –  meow Jul 2 '12 at 10:12
    
Also interestingly, the high max numbers show up only for CPUTIN and AUXTIN. The temperatures of the 4 cores themselves have the max around 60°C. –  meow Jul 2 '12 at 10:13
    
Hum, readings on the internet say CPUTIN is rarely accurate. If the cores would have hit 90C+ this would have been a problem. Anyway, I would run some air in the PC first, just to rule out that possible cause. –  M'vy Jul 2 '12 at 10:41
show 5 more comments

1 Answer

I suspect a conflict specific to your machine.

I see you know the Sysinternals tool. Try process monitor. Have it running and request the > 7 queue. Take note of the times of the stuttering. Look at the procmon log especially for file or network opens to malformed paths. There are timeout that eventually release but will block the whole system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.