Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a computer running Windows 7 that shares some files on the network. This works fine for a while until for some unknown reason the computer decides that it is connected to a new, unknown public network and disables the file sharing capabilites.

Nothing physically changes with the computer, it is still connected to the same network via ethernet cable. But it does misidentify the network every other day, just plugging out the ethernet cable and putting it back in leads Windows to correctly identify the work network and enabling the share again.

Is there some way to stop Windows from trying to identify the network automatically, and just tell it that the network on that computer will never change?

share|improve this question

If I remember correctly, you can tell Win7 (and Vista) to not query what type of network, but to assume it's "Home, Public, whatever".

Last I saw, it was a checkbox in the lower part of the "Choose a network type" window. Maybe locking it to a particular type would help.

Don't have a windows machine here at the moment to poke around, so that's from memory...

share|improve this answer

If your system runs Bonjour try to uninstall it.

Also try.

Type Cmd in the Start Search text box. Now instead of hitting the Enter key press Ctrl-Shift-Enter keyboard shortcut to run a Command Prompt as an Administrator.

Allow elevation.

  • Type route delete press enter.
  • Type ipconfig /flushdns press enter.
  • Restart.

Hope this helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.