Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So the issue is this:

I've installed sshfs on Ubuntu 12.04 and I'm trying to connect to a couple of remote servers. So initially the mount seams successful. Sometimes Gnome even picks it up and displays the "new device found" box at the bottom of the screen. but from here on there is not much that works. Or at least not any more. The first couple of times i connected it seamed to work fine, and I was able to transfer some files, then i disconnected using fusermount -u <folder> and after reconnecting a little later the trouble started. Now after executing sshfs -o ServerAliveInterval=15 -o reconnect -C -o workaround=all -o idmap=user root@<host>:/ <folder>, when I change directory into the mount-point, the shell just freezes. Strangely ls -al <folder> works when listing just the root of the remote system, but nothing more. Also every file-explorer I've tried freezes just like cd <folder>.

To me it seamed like there was some kind of zombie thread or something hanging around my system, due to the fact that it did work the first time, so I have tried rebooting but no luck.

sshfs -V gives this:

SSHFS version 2.3
FUSE library version: 2.8.6
fusermount version: 2.8.6
using FUSE kernel interface version 7.12

So yea, any ideas?

share|improve this question

1 Answer 1

How long have you waited for the freeze to resolve? It might just been transmission issues between you and the server in question.

I use sshfs between my system and a friend's who lives in the boonies (offical term!), he's on a overland wireless which occasionally drops out (we think his receiver is waving in the wind, losing signal lock).

If I wait, it DOES eventually sync up and do things, but occasionally it'll just hang for a few minutes.

Patience GrassHopper!

share|improve this answer
I have tried waiting for some bit, maybe 10-20 minutes, but no luck. Maybe it just needs a couple of hours? ^^, –  Andreas Hagen Jul 3 '12 at 9:17
One would hope not!! You might try logging in with sshfs -d' or sshfs -o LogLevel=Debug` (or 'Debug2') to turn on verbose mode... see if anything enlightening is printed. –  lornix Jul 3 '12 at 10:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.