Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

enter image description here

This happens on Google Accounts like Gmail, Twitter.. a few other SSL pages and some non SSL pages. I have tried those pages on Chrome and they work fine.

I have tried following the View > Character encoding suggestion here but not working. Removed all addons, tried without addons, re-installed FF, restarted, cleared cache of entire PC completely.. still some pages show this.

share|improve this question
That's nothing to do with character encoding -- it rather looks like a missing mime type declaration (and a binary being displayed). What are the first few characters (which are cut-off in your screenshot)? They could indicate the real file type. Another possibility might be something going wrong with SSL, and you're looking at the still encrypted content. – Izzy Jul 2 '12 at 12:35
SSL I doubt it as it works fine for Chrome and other browsers and other Firefox users within my offices: First few characters are not cut, off. The first few characters ARE IN FACT the question mark diamonds: ��}k��u����V4 – TheBlackBenzKid Jul 2 '12 at 14:02
You could try to connect to a non-SSL site exhibiting the problem, and trace the connection using Wireshark. That should give you access to the raw bytes exchanged between your computer and that site. – MvG Jul 16 '12 at 14:02

I have the same problem.

  1. In the address bar, type: about:config
  2. Promise to be careful
  3. Type in the filter bar: encoding
  4. Double click on the 'value' column of network.http.accept-encoding.
  5. Change the 'string value' from gzip, deflate to true.

You can also try making sure the proxy is set to Auto in

Tools > Options > Advanced > Network > Connection > Settings > No Proxy

I still get problems with Google and Gmail though. Same thing

share|improve this answer
This does not work. I saw this and a few other similar solutions from Firefox.. – TheBlackBenzKid Jul 12 '12 at 8:02

Some suggestions which are more in the nature of tests, to better understand the problem:

  1. In the case that the website use fonts that you do not have installed or Firefox cannot read properly:
    In Tools>Options>Content locate the Advanced button under "Fonts & Colours" and uncheck "Allow pages to choose their own fonts"
  2. Try again in View->Character Encoding, but choose other encoding such the two Western.
  3. As this can be a problem with the fonts on your computer, please give us the address of a page that shows this problem in consistent manner, so we can analyze which character encoding it uses.

It would also help to know what is your operating system, its language, and which other language packs you have installed.


I have analyzed your posted page, and I must remark that I have never seen a page garbled to that degree. The page has no resemblance at all to the Google Account page - not even the slightest. Everything is wrong, starting with the header and continuing to the body. The body itself is a garbage-can of strange characters inter-spaced with end-of-lines (carriage-return/line-feed). The character-encoding is not identifiable - not ansi/utf8/utf16. Firefox auto-detect did not succeed any better in identifying it.

Conclusion: Some proxy software between you and is garbling your pages.

If you have any sort of proxy software installed, I suggest to uninstall it.
If you use any DNS provider either than your ISP, return to that of the ISP, or try Google DNS.

Otherwise, to test, you could boot in "Safe mode with Network" and see if the problem disappears. If it does disappear, then some installed product is responsible, which you need to find out (see autoruns).

If the problem remains, then the only further suggestions I can make are :

  • Use Windows Update to ensure that your system is fully patched (including optional updates)
  • Check for virus infection using several well-known anti-virus products
  • Use the System File Checker to verify system integrity
  • Verify the web parameters of your PC and router, especially concerning DNS
  • Get in touch with your ISP's Support
share|improve this answer - this redirects to… - the Firefox is 13.0.1 and is Windows Home 64bit - In English; language packs loads - but all default and do not use them. I tried your suggestions but still nothing. – TheBlackBenzKid Jul 12 '12 at 10:55
Strange, this page is quite innocently encoded in utf-8 and uses the arial font. No way that anything could go wrong with arial without greatly lousing up you computer. Does this page display correctly (same text 3 times) ? – harrymc Jul 12 '12 at 12:33
That page works perfectly. – TheBlackBenzKid Jul 12 '12 at 12:35
Could you do SaveAs to the google account page while it's full of diamonds in complete webpage format and post the whole thing (maybe zipped?) for us somewhere. – harrymc Jul 12 '12 at 14:11
up vote 0 down vote accepted

I have resolved this issue. I just downgraded to Firefox 7.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.