Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm completely frustrated. I'm an owner of a OCZ 8GB Rally2 which I've used flawlessly for about 4 months now, and all of a sudden this week I begin getting errors telling me that I can't delete a file due to "make sure the disk is not write-protected, full or and the file is not in-use" dialog. Here's what I've tried:

  • Deleting the file using FileASSASSIN (it's worked on everything else but files on this darn flash drive)
  • Formatting the flash drive and then restoring the backed up information (I format to NTFS, FYI)

Any suggestions on what to do?

share|improve this question

Use Unlocker:

alt text

If that doesn't work, there are alternatives that will remove the file upon reboot, before Windows has a chance to lock them. 2 such programs are:

Boot Deleter:

alt text

MoveOnBoot:

alt text

share|improve this answer
1  
Nice screen capture work... I'm impressed =8-) – Yuval Sep 21 '09 at 5:40
1  
+1 because I can't give +2. Really good answer, I can see you've earnt your rep. – Szetak Sep 21 '09 at 6:41

When I get this error message, I use Process Explorer's handle-search feature to find which application is holding which resource in the system, so maybe this can help you too.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .