Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Fujitsu / Siemens PC with Windows Vista installed and I am trying to repair it after I had to replace the motherboard: The hard disk has three Windows partitions (partition 2 is marked as bootable). I checked this using Linux RIP, which I had booted from a USB stick.

I have got hold of the original Windows Vista System recovery DVD for this model and I am trying to repair the operating system.

I have the following problem. When I start the DVD, after showing the progress bar for a a few seconds, the screen turns black and only displays the mouse cursor. It then stays like this for ages and I have to reboot.

I then had the idea of marking the partitions as non-Windows (did it again using RIP Linux, fdisk). Now the DVD boots into the Windows installer but it does not see the partitions it has to repair.

Has anyone encountered this problem already? Any clue as to how to solve this (I want to boot from the recovery DVD and then try and repair the existing partitions)?

EDIT 1

Thanks for the suggestions on the forum and in chat. Copying the first 440 bytes from a working Windows Vista partition and writing them to the MBR and the bootable partition of the broken system has solved the problem.

EDIT 2

Here is the happy end.

Unfortunately, partitions 1 and 2 (where the old system was) were too compromised to recover. Partition 3, containing the data I wanted to recover, was damaged too, so it was not possible to copy out all the files contained in it.

After fixing the boot record problem I booted again into RIP Linux, recreated partitions 1 and 2 (I do not know why, but Windows could see them right after boot and later could not see them any more. So, I am not sure if the partition table is stored in two different places and these copies had become inconsistent, but to be sure I just deleted these two partitions using fdisk and created them again).

I then put a fresh ntfs on both partitions and rebooted from Linux into the Windows installation again. This time Windows installed without a problem. It then detected partition 3 (drive D:) which I had not touched and scanned it. It fixed the errors on the file system and all the photos (some family photos) seem to be back.

Once more thanks to lornix for the hints.

share|improve this question
    
I have also thought that maybe this is a known Windows Vista bug, in such a case I would like to be sure of this before I proceed to format the hard disk and reinstall from scratch. I would like to be sure though, because I have some data on the disk that I would like to recover (I need to run chkdsk). –  Giorgio Jul 2 '12 at 16:50

1 Answer 1

up vote 1 down vote accepted

Sounds like the MBR (master boot record) is corrupted on your computer. The windows CD/DVD's check something (!), which changes how they boot... consider installing windows on a bare system... it boots, whirrs for a moment, then starts up the windows installer, while a working system whirrs, then says "Press any key to boot from CD/DVD" ...

So whatever windows uses to detect this is borken on your computer and it's locking up the windows cd/dvd checking routine. Yay for failure trapping! (</sarcasm>)

In a pinch... (pinch, mind you!!) you COULD extract the boot code from a WORKING system using the SAME version of windows, using your RIP CD. I'll describe the method, implementation and required 'nerves of steel' are up to you...

Boot your RIP CD on the WORKING system, also need to insert a flash drive or such, we need to store 440 bytes somewhere

make sure your flash drive is mounted and accessible.

dd if=/dev/sdX of=/path/to/flash/drive/mybootcode.img bs=1 count=440
    (replace /dev/sdX with appropriate boot drive, usually /dev/sda)

this will copy the first 440 bytes from the MBR to the 'mybootcode.img' file

make sure the file has been written, sync, umount the flash drive

on your borken system... same batsteps, same bat... yeah...

again, insert, mount, check the flash drive

dd if=/path/to/flash/drive/mybootcode.img of=/dev/sdX bs=1 count=440 conv=notrunc
    (again, /dev/sdX with your appropriate drive, usually /dev/sda)

umount, shutdown, remove RIP CD...

system MIGHT be bootable now, and MIGHT be usable with windows repair CD/DVD

Now someone out there is saying... but the sectors are 512 bytes... why didn't we just copy the first sector? Well... consider the CONTENTS of the MBR.

From Wikipedia, there's a table there that I'm not going to even attempt to recreate here, my markdown-fu is still weak...

the First 440 bytes is the bootstrap code... while the following 72 bytes include various data, but most importantly... the PARTITION TABLE!!

Now, unless you'd like to rebuild that by hand (or with some tool or another) ... it's best we don't lose (or overwrite!) that information!

Which is why, Virginia, we don't copy the entire 512 byte sector verbatim.

share|improve this answer
    
I have Windows Vista on my laptop. I am going to try this. After all, I can first make a backup of the first sector on the target system before I overwrite the first 440 bytes. Thanks for the hint. I will let you know if it has worked. –  Giorgio Jul 2 '12 at 16:57
    
No, wait! I have grub on my laptop! So /dev/sda will not contain the Windows bootstrap code, right? Where else can I get it from? Can I find it at the beginning of the Windows Vista DVD itself? –  Giorgio Jul 2 '12 at 17:01
    
no, the DVD has a different style... grub usually keeps a copy of the original boot sector in the /boot/grub subdir... look there, might help. I don't have any windows machines to play with here. Although I could fire up the Win7-VM... But you MIGHT be able to get it from the first sector of the partition windows is installed on. (that being the other place a boot sector can be) –  lornix Jul 2 '12 at 17:04
    
Is it /boot/grub/boot.img? –  Giorgio Jul 2 '12 at 17:07
    
it MIGHT be... been a while since I looked up the specifics (ha! or had a dual boot machine!) –  lornix Jul 2 '12 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.