Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I press middle mouse button, it opens:

alt text

It is so difficult to control the scrolling. Is there any way to disable this?

share|improve this question
tsk, no hand drawn circle? – hyperslug Sep 21 '09 at 6:30
@Hemant, Chrome I assume? – hyperslug Sep 21 '09 at 6:39
Yes. I am using Chrome. – Hemant Sep 21 '09 at 6:39
Obvious answer: Can't you just not press the middle button then? – Matthew Lock Sep 21 '09 at 7:45
I need to press it to open the page in new tab, but sometimes this scrolling is enabled accidentally. – Hemant Sep 21 '09 at 8:11
up vote 16 down vote accepted

There's now an extension for this:

Earlier versions of Chrome required restarting the browser for this extension to take effect, but that appears to no longer be the case.

share|improve this answer
Now THIS solves the issue. Thanks, dude! – JoePerkins Sep 13 '13 at 12:18
As of Version 33.0.1750.154 Stable for Windows, restarting Chrome is not necessary to take effect, only refreshing the page. Do you mind if I suggest edit to your answer? – yurkennis Apr 8 '14 at 21:29
this is not working for me unfortunately – anon58192932 Jul 11 '14 at 5:27
@yurkennis I've updated the answer to say it may no longer need a restart but I couldn't find info about the specific version where this was fixed and whether it's just Windows or all platforms; do you have a link? – Toby J Jan 22 '15 at 14:50
Doesn't need a browser restart, but does need a page reload. – BobStein-VisiBone Feb 10 at 5:35

Get the latest drivers for your mouse and see if you can reassign the wheel click to a macro through its settings.

It should be reassigned to: Middle-click [very short sleep] ESC

If you can't get drivers with this feature, I suggest you write a very simple script in Autohotkey to do the exact same thing.

It should look something like this:

#IfWinActive ahk_class Chrome_WidgetWin_1
Click Middle
Sleep 10
Sendinput {ESC}
share|improve this answer

In your mouse control panel, you need to disable the middle button, if it will allow you to.

The multi-directional cursor vs a standard up/down cursor should also be because your window is too small, and has both vertical and horizontal scroll bars.

If you make your window bigger, the scroll should only be up/down :)

share|improve this answer
He'll probably want to keep middle button for stuff like Open link in new tab. – hyperslug Sep 21 '09 at 6:33
Yeah...Cant loose "Open link in new tab". Just want to disable the scrolling. – Hemant Sep 21 '09 at 6:41
I guess you're at a loss then. Chrome isn't exactly a very configurable browser. And yes, middle-click scrolling there sucks (it's interestingly also magnitudes slower than normal scrolling, I just wonder why). You might be able to rip that functionality out of the source and build yourself but for a project that size it's not a pretty task to do. – Joey Sep 21 '09 at 6:55
You can post a feature request here:… – hyperslug Sep 21 '09 at 7:00
I control-click for Open in New Tab :) – warren Sep 21 '09 at 12:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .