Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I enter a search criteria in the Omnibox, Chrome seems to offer me a blank page instead of completing the search & offering the results.

Note that if I opt for a Google Instant/Omnibox suggestion, it works fine

enter image description here


However, I choose to ignore the suggestion and try to do a Google search, I get a blank page.

enter image description here


enter image description here

What can I do make the Omnibox search complete successfully?

share|improve this question
    
You are not the only one superuser.com/a/444251/71027 –  HackToHell Jul 3 '12 at 5:32

4 Answers 4

up vote 1 down vote accepted

Clearing cache doesn't work.

To solve this problem, disable instant search. This is a widespread issue occurring today, and it appears that is the fix.

It worked for me, I hope it works for you.

share|improve this answer
    
seems to work, will try more. Thanks! –  Sathya Jul 3 '12 at 5:54

Wow all that extra stuff. All you need to do:

Add a new a search engine in wrench >> settings >> search “Manage Search Engines”.

Under “other search engines” add a new search engine using this address for the URL:

http://www.google.com/search?q=%s

Name it “Google 2″ or whatever you want. Works like a charm.

share|improve this answer
1  
Chrome team member and Omnibox owner has mentioned you should not do this news.ycombinator.com/item?id=4192779 –  Sathya Jul 3 '12 at 13:43

This is what fixed it for me:

1. Cleared my cache and cookies for the last week.

Went to: chrome://chrome/settings/ At the bottom of the page you'll see 'Show Advanced Settings' and Clear Browsing data...

2. Deleted Google Drive Extension

Open a new tab, right click on Google Drive Icon and Delete Extension

3. Turned instant search ON (it was originally turned off in my computer)

I suppose turning it off and on again would do the trick...

4. Restarted Browser

The problem is fixed and the omnibar search has been working fine for the last hour. Both instant search ON and OFF work for me...

Cheers

share|improve this answer
    
Ok this is weird, the problem is back, but the weirdest thing is that everything works fine if you enter incognito mode... –  victmo Jul 3 '12 at 5:51
    
no, clear browsing data didn't make any difference for me. –  Sathya Jul 3 '12 at 5:54
    
@Sathya: Did you restart your browser? Like I commented before being downvoted "The problem is back..." but after I restarted it's working again... –  victmo Jul 3 '12 at 6:34
    
@Sathya Some users are reporting that just enabling and disabling extensions work for them... –  victmo Jul 3 '12 at 6:54
    
for me it was the turn off/on instant which seemed to have worked - thanks for editing in your answer with some possible options –  Sathya Jul 3 '12 at 7:12

I disabled instant search from Google.com's search settings option, which BTW, does not appear till you first search something (or maybe I can't find it). This solved it. However, enabling Instant Search again seems to keep the problem away and I am no longer facing it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.