Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a standard keyboard with debian 6.0.5. until now everything were fine. Now the numeric part of the keyboard does not work. numlock is on. if I press some random keys it does right click or opens the history in the browser. Can anyone help?

[UPDATE]

After some testing, I got that numbers on numeric part are moving mouse pointer.

4 --> move left

6 --> move right

8 --> move up

2 --> move down

share|improve this question
up vote 3 down vote accepted

I imagine you're running Gnome (The default), which I don't use, but it sounds like you've enabled "Mouse Keyboard Emulation"

On my KDE system, it's toggle-able with ALT+F12, I'll check here in moment for Gnome.

(Gnome users: How to get numpad out of "mouse emulation" mode. Try SHIFT+NUMLOCK (Setting may be found in Universal Access) )


Some Pictures... 'cause pictures are cool! (My sincerest apologies to the Gnome users, as I don't have a Gnome machine to take screenshots)


The two modules in System Settings to look at for mouse emulation settings and information: "Shortcuts and Gestures" and "Input Devices".

System Settings Choices


I've circled the important things to select, "Global Keyboard Shortcuts", "KDE Component: KWin" and the hotkey in question: "Mouse Emulation: ALT-F12"

Keyboard HotKeys


And in the "Input Devices" Module: Choose the mouse device, then examine the checkbox for "Move pointer with keyboard"

Mouse Settings

Hope this helps.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .