Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently installed ArchLinux with Xfce4 and NetworkManager on an Eeepc 1005HA. NetworkManager is mostly fine - it auto-connects to ethernet and will auto-connect for wifi too if the connection is already set up.

My problem is that it requires a password every time I wish to edit or add connections. Also when selecting a network from the systray menu it doesn't ask for a network key, so I have to then go and edit it before it will work.

I have tried following https://wiki.archlinux.org/index.php/NetworkManager#Set_up_PolicyKit_Permissions but dbus-launch breaks my mouse and the .pkla file doesn't seem to do anything.

My user is already a member of wheel and network as well as a good few others, and network-manager-applet is installed.

Hope you can help!

share|improve this question
    
Turns out I had a typo in my .plka file, so I no longer need a password to edit/add/delete. I'm still not being asked for a wifi key when I select one though... –  darkblackcorner Jul 4 '12 at 8:03
    
Have you tried installing gnome-keyring? I believe it includes the dialog for inputting these network keys/passwords and such. –  dma1324 Mar 14 at 4:36
    
I have since changed to using wicd, and it works great :) –  darkblackcorner Mar 15 at 18:52
1  
@darkblackcorner Please remember to post an answer below and mark it accepted if you think that's an actual answer to your question. Thanks! –  Daniel Beck May 3 at 18:33
add comment

1 Answer

up vote 0 down vote accepted

Turns out I had typo in my .plka file, so the issue is resolved.

I have since switched to using wicd instead.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.