Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We are using class-C IP addresses in our network setup.

The first scope of IP addresses are in 192.168.0.xxx. Since all the IPs are exhausted in this scope we created another scope of Class-C IP in the same Domain Controller. This scope has IP addresses in 192.168.3.xxx.

The issue we are facing is, whenever a client with IP address in the 192.168.0.xxx scope, tries to copy a file to a client with IP address in scope 192.168.3.xxx the copy is dead slow.

For e.g., transfer rate of a 1 GB file between clients in same IP scope will be around 35 MBPS or more whereas copy of the same file between clients in different IP scope will be around 5 MBPS or sometimes even lesser (sometimes drops to 0).

What is happening here? Is there a solution to make copy faster. The type of work we do requires huge data transfer between clients and changing the IP scope to a class A scope may be a out of question since we are a little short on resources to do the transition.

Am I missing some setting or something on the Domain controller or the router which is causing the copy to go so slow.

This issue is not fixed to any specific kind of OS, it happens across all types of OS we have - Windows or Mac.

share|improve this question

migrated from stackoverflow.com Jul 3 '12 at 12:54

This question came from our site for professional and enthusiast programmers.

    
Switch to a class A network so everyone knows how to find everyone else. 10.x.x.x. –  bmargulies Jul 3 '12 at 12:26
    
Classful networking has been replaced by CIRD since 1993. This means no more 'Class A' etc etc, but /X. E.g. /8 for old class A networks. This also allows you to create a /23 with up to 512 IPs in a network rather then tie two /24 ('c')'s together. –  Hennes Sep 10 '13 at 12:31

1 Answer 1

Without knowing your entire network topology, this is quite hard to answer.

My guess is that everything is going via a gateway and the traffic is being doubled up somewhere (e.g. going in and out of the gateways same lan port).

My advice would be to change the subnet mask - If you are only using 192.168.0.xxx and 192.168.3.xxx - simply change the subnet mask to 255.255.0.0 and everything should work fine.

share|improve this answer
2  
Even stricter subnet mask is possible for those two classes: 255.255.252.0 –  Radoo Jul 3 '12 at 13:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.