Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Eclipse 3.5.2. I want to install the CDT plugin so that I can compile C/C++ programs.

I attempted to install the CDT plugin and it failed, given the following error message:

Cannot complete the install because one or more required items could not be found.
  Software being installed: C/C++ GCC Cross Compiler Support 1.1.0.201206111645 (org.eclipse.cdt.build.crossgcc.feature.group 1.1.0.201206111645)
  Missing requirement: C/C++ Managed Builder UI 8.1.0.201206111645 (org.eclipse.cdt.managedbuilder.ui 8.1.0.201206111645) requires 'bundle org.eclipse.ui.console [3.5.100,4.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: CDT GCC Cross Compiler Support 1.1.0.201206111645 (org.eclipse.cdt.build.crossgcc 1.1.0.201206111645)
    To: bundle org.eclipse.cdt.managedbuilder.ui 8.1.0
  Cannot satisfy dependency:
    From: C/C++ GCC Cross Compiler Support 1.1.0.201206111645 (org.eclipse.cdt.build.crossgcc.feature.group 1.1.0.201206111645)
    To: org.eclipse.cdt.build.crossgcc [1.1.0.201206111645]

Has anyone managed to install/use the CDT plugin with Eclipse v 3.5.2 ?

share|improve this question

1 Answer 1

Do you have GCC installed? If I remember correctly CDT does not include the compiler. You need to find a C compiler and install it before installing CDT.

share|improve this answer
    
Yes, I have gcc devtools installed. Most of my programming is C/C++. –  Homunculus Reticulli Jul 4 '12 at 15:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.