Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently bought an Samsung UE32ES5500 and I want to connect it to the internet. Not wanting to buy an expensive Samsung wireless adapter for the TV, I've decided to use an ethernet cable. Because the Internet cable passes through underground to the bedroom and the TV is located in the living room, i decided to put a router in the bedroom, and receive it's signal in the living room using a windows 7 laptop.
Afterwards I connected the laptop to the TV through an ethernet cable, and bridged the two connections in Network Connections in Control Panel on the laptop. The TV successfully finds the laptop (and the router I think) but still cannot connect to the internet. Does anyone knows a solution to this problem? (the connections must be bridged because I want to have only one network in the house).

It is important to keep the TV on the same subnet as the router, as I use an Android device to control the TV over the network.

share|improve this question
add comment

1 Answer

Instead of bridging the connections, use Internet Connection Sharing.

Open the Network Connections view (likely where you bridged the connections - for reference open the Network and Sharing Center, and click Change Adapter Settings, or type "View Network Connections" into the start menu.) and undo any bridging you have previously done.

After this, RMB on the connection that has the internet (the wireless adapter, if I've understood correctly), and open the Properties. Open the Sharing tab, and select "Allow other network users to connect through this computer's Internet connection". In the drop-down list below, select the wired adapter that your television is connected to.

Press Okay, and with luck it should all work happily.

share|improve this answer
    
I've done this before, the TV connects to the internet, but is not on the same network as the router (the tv-controling app on the android phone connected to the router can't find the tv –  Serban Razvan Jul 4 '12 at 14:48
    
Okay, sorry, I wasn't considering any kind of remote. That won't work because the laptop will be assigning a different subnet to the TV. –  Jeeva Jul 4 '12 at 15:05
    
Serban, check if you can provide TV's IP address manually into the android app. That should do the trick –  Amadeu Jul 4 '12 at 15:05
    
If I remember correctly, Samsung don't allow you to do anything like that. May be wrong / may have changed since I last checked, though. –  Jeeva Jul 4 '12 at 15:08
    
So you say to disable dhcp on the router and the laptop and give them an ip by myself. When I get home ill try with 192.168.1.x subnet 255.255.255.0 –  Serban Razvan Jul 4 '12 at 15:16
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.