Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have already disabled autoformatting from the autocorrect menu of the proofing tab in Excel options. For whatever reason I keep experiencing this formatting change even after explicitly setting the format in a blank cell. My table contains four columns, A B C and D. A, B, and C are formatted as time and D should be formatted as general. What happens, however, is after entering times in A and B (the time in C is calculated) any data entered in D gets formatted as time. I can change it back to general after data entry, but even if I set the format of column D in subsequent blank rows it still gets changed to time format!

This behavior is new in Excel 2010 as I'm using the same sheet created in 2007. Any ideas?

share|improve this question
up vote 5 down vote accepted

Excel assumes you have not applied a format if you use general, so it tries to find the best format for the data you entered. To disable this, go to File => Options => Advanced and uncheck the option for "Extend data range formats and formulas."

Excel Options

Otherwise, you can set column D to something like number, text or even a custom format, and Excel will stop changing the formatting of that column.

share|improve this answer
    
Awesome. When changing the format of a filled cell to "General" it would change to number, so I had presumed that if I set the format of the empty cells to "General" it would do the same. I've now specified the column as "Number" and all is well. – Josh Jul 5 '12 at 19:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .