Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I own a domain name and have been using it for email, hosted through a friend's company, for the past years or so. I'm attempting to switch over to Google's hosting (Google Apps for your Domain) and have been at it most of this week, but things haven't switched over yet.

What I've done so far:

  1. Switched the primary DNS server from my friend's to my registrar's (000domains; I own & have primary control over the domain registration)
  2. Added the Google verification code to a TXT record
  3. Removed my friend's mail server from the MX record and added MX records for Google's server

I completed steps 1 & 2 the night of July 3rd, and Google picked up that change sometime overnight. At this point, I completed step 3, so we're now 48 hours post-change. Yet when I look up the MX record via dig (dig MX DOMAIN) I still get the MX records for my friend's server. I have verified (many times) in the 000domains control panel that the MX records are set up properly there.

I know that at some point the MX record should be removed from my friend's DNS server, but he's very slow to respond lately so this may take a few more days. I'm still getting email to the old server, so nothing is being lost, but I really want to get this finished. What else can I do, or what steps have I missed, to make this switch complete?

share|improve this question
Did you update the serial in the DNS record? I assume so (from your saying "Google picked up..."), but just to make sure. If changes are made to the zone file, the serial of it must be increased to have the changes propagated. Second, as you switched your primary to your registrars, and that one doesn't show the latest MX changes: where did you update the zone file? This must be done at the primary -- and that's the one not showing it. If you did update on the primary and increase the serial, contact the DNS admin, as the config has not been reloaded properly. – Izzy Jul 6 '12 at 11:15
No, I have not changed the serial. Google picked up the new TXT record but now I wonder if that happened after my current host did it, and it took him a day or so to tell me that he'd done it. I didn't do an official zone transfer, I just added the records through the registrar's DNS management interface. I don't see a way to edit the serial there or load a zone transfer file, so I may have to contact support to find out how to do that. – alroc Jul 6 '12 at 12:48
up vote 2 down vote accepted

In order for the changes to be propagated, the serial in the zone file needs to be updated. Quoting the documentation:

The <serial-number> directive is a numerical value incremented every time the
zone file is altered to indicate it is time for named to reload the zone.

So as your comment says, you forgot this step -- so the zone file was not loaded by the primary DNS server, and never made it anywhere. So I wonder what "Google picked up" -- but to solve your issue, increment the serial number in your zone file. If I may suggest: For my zone files' serials, I use the pattern YYYYMMDDNNN (i.e. 4-digit year followed by 2-digit month plus 2-digit day, and 3-digits for the "change number of the day" -- unlikely to have more than 999 changes a day), e.g. for the first change today 20120706001. This is a valid serial, and you always can see the time of the latest change easily as well as increment it easily.

Having increased the serial, the DNS server should reload the zone file and propagate changes automatically.

share|improve this answer
I don't have access to the serial in the zone file via my registrar's interface, so I've opened a support case with them to hopefully get that sorted out. – alroc Jul 6 '12 at 13:49
Oh, you didn't say that -- so the registrar provides some Web interface for that, and it contains no serial field? In that case, they should handle the serial-update automatically. But as you opened a ticket with them, they should get that sorted out. Make sure they tell you what went wrong -- not only that I'd like to know, but it might prove useful to you the next time ;) – Izzy Jul 6 '12 at 14:34
Finally got the registrar to bump the serial # on my record on their DNS servers and it's working. Thanks for the pointer. – alroc Jul 9 '12 at 1:43

It seems to be an issue with DNS caching from where you are trying to check the status. I would suggest trying third-party free websites to query from there network.

share|improve this answer
I have tried multiple methods of checking the status and all return the same result. – alroc Jul 6 '12 at 12:46

If you need a fastest update of your MX record, you can reduce your TTL at the minimum. And when the other DNS servers have updated your TTL in their DNS, change your MX record. In case of you have completed the Step 1 and 2.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .