Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am in a LAN and have to use a proxy given to access the web in a very limited way. I can't even use google, github.com or SE sites. However I can use ssh to log into a server(also in LAN), which I have root access so basically I can do anything I want with it. So I was thinking that maybe I could use that server as a proxy so I can visit sites through it.

I tested it using ssh -vT git@github.com which gave a proper response. And In my computer I can't do this.

Also I tried downloading something from the gun.org using wget, which can't be done in my computer too. And it succeeded on that server.

I don't know if that's enough to say that this server have full access to the Internet. But I assumed so and I installed squid3 on it. After trying some while, I failed to get it working.

I got this after I run squid3 -k parse

2012/07/06 21:45:18| Processing Configuration File: /etc/squid3/squid.conf (depth 0)
2012/07/06 21:45:18| Processing: acl manager proto cache_object
2012/07/06 21:45:18| Processing: acl localhost src 127.0.0.1/32 ::1
2012/07/06 21:45:18| Processing: acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1
2012/07/06 21:45:18| Processing: acl localnet src 10.1.0.0/16   # RFC1918 possible internal network
2012/07/06 21:45:18| Processing: acl SSL_ports port 443
2012/07/06 21:45:18| Processing: acl Safe_ports port 80     # http
2012/07/06 21:45:18| Processing: acl Safe_ports port 21     # ftp
2012/07/06 21:45:18| Processing: acl Safe_ports port 443        # https
2012/07/06 21:45:18| Processing: acl Safe_ports port 70     # gopher
2012/07/06 21:45:18| Processing: acl Safe_ports port 210        # wais
2012/07/06 21:45:18| Processing: acl Safe_ports port 1025-65535 # unregistered ports
2012/07/06 21:45:18| Processing: acl Safe_ports port 280        # http-mgmt
2012/07/06 21:45:18| Processing: acl Safe_ports port 488        # gss-http
2012/07/06 21:45:18| Processing: acl Safe_ports port 591        # filemaker
2012/07/06 21:45:18| Processing: acl Safe_ports port 777        # multiling http
2012/07/06 21:45:18| Processing: acl CONNECT method CONNECT
2012/07/06 21:45:18| Processing: http_port 3128 transparent vhost vport
2012/07/06 21:45:18| Starting Authentication on port [::]:3128
2012/07/06 21:45:18| Disabling Authentication on port [::]:3128 (interception enabled)
2012/07/06 21:45:18| Disabling IPv6 on port [::]:3128 (interception enabled)
2012/07/06 21:45:18| Processing: cache_mem 1000 MB
2012/07/06 21:45:18| Processing: cache_swap_low 90
2012/07/06 21:45:18| Processing: coredump_dir /var/spool/squid3
2012/07/06 21:45:18| Processing: refresh_pattern ^ftp:      1440    20% 10080
2012/07/06 21:45:18| Processing: refresh_pattern ^gopher:   1440    0%  1440
2012/07/06 21:45:18| Processing: refresh_pattern -i (/cgi-bin/|?) 0 0%  0
2012/07/06 21:45:18| Processing: refresh_pattern (Release|Packages(.gz)*)$      0       20%     2880
2012/07/06 21:45:18| Processing: refresh_pattern .      0   20% 4320
2012/07/06 21:45:18| Processing: ipcache_high 95
2012/07/06 21:45:18| Processing: http_access allow all

I deleted some allow and deny rules and added http_access allow all so that all the request would be allowed.

After configuring my computer, I got this error:

Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

And the log in the server showed that my TCP requests had all been denied.

So, first of all, is what I am trying to do achievable? If so, how to configure the squid in the server so that I use it as a proxy to surf the Internet?

My computer and the server both run Ubuntu11.04.

And server IP:10.1.242.26 my IP:10.1.232.23

Thanks for any help~

share|improve this question

1 Answer 1

Strange you do have "allow all"... could you post the squid.conf?

Or Try this:

Change "http_access allow all" to "http_access deny all" and before that line add the allow rules you need, for example: http_access allow localnet

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.